We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Winrescue without SRV Firewall (can't disable firewall)


K-Xander
27-04-2015, 16:33
You're awsome! Worked like a charm and yes, modifying registry was the first thing I tried to do but all I got was the registry of the windows xp lite (rescue OS) and didn't knew about Loading/Unloading Hive that could edit some other registry file manually.

Thanks a lot for taking your time to help me out with this. Really appreciated !

alvaroag
27-04-2015, 16:02
I think I've got the solution. You can disable the firewall from the registry. Just open Regedit, select HKEY_LOCAL_MACHINE, go to File -> Load Hive. Look for C:\Windows\system32\config\SYSTEM (assuming C:\ is where your Windows Server is installed). It will then ask you for a name, for example, "Rescue". Now, go to HKEY_LOCAL_MACHINE\Rescue\ControlSet001\Services\S haredAccess\Parameters\FirewallPolicy. Inside, you will find two keys: "PublicProfile" & "StandardProfile". Inside each of them, change the value of "EnableFirewall" & "DoNotAllowExceptions" to 0. Sometimes, "DoNotAllowExceptions" may not exist, so just create it as 32-bit DWORD with value 0. Then, select your "Rescue" key, go to File -> Unload hive. Then, reboot into Windows normally, and the firewall should now be disabled. Don't stay like that for long, specially on windows.

K-Xander
27-04-2015, 14:54
Unfortunately I don't have KVM/IP . That costs an extra of 180 EUR till august. I assumed the winrescue will actually contain what the guide says.

alvaroag
27-04-2015, 14:43
Do you have the KVM/IP option on your server? If so, you can access to the server as if you were in front of it, so there you can boot windows normally and disable the firewall from the control panel.

K-Xander
27-04-2015, 07:59
Hello

According to this thread https://forum.ovh.ca/showthread.php/...escue-probleme, I am one of the "lucky" guys who got into the same problem after running a custom firewall rule and seem to have blocked my remote connection.

There is no SRV firewall icon while I m connected to VNC and unfortunately that guy's link who has provided as a script to disable the firewall isn't working. This is really annoying as OVH failed to offer one of the most important option which they have for win rescue.

Any idea what can be done in this case?

ns203854 if it helps. (already got an opened ticket and hopefully it won't take ages to get this one fixed)