We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Lost password for dedicated server?


FrederikC
06-10-2015, 20:41
Did try that.. Didn't work..

alvaroag
06-10-2015, 20:17
Not sure if this may help. Some Linux distributions are configured, by default, to disallow direct root login. On such cases, you should use another user, configured in the installation, and then use sudo to elevate your privileges. Not sure if that happens with OVH, as I've only tried Proxmox.

Another option, which might be just luck. If your server is configured with SOFT RAID, you should use "/dev/mdX" instead of "/dev/sdXY". Not doing so could lead to random behaviour, as both disks would not be synchronized.

FrederikC
06-10-2015, 19:48
Well this was kind of a strange error.
I was able to access the system on /dev/sda2 and change the password for root
However - after rebooting Ubuntu again, i weren't able to login?

I then started in rescue again, and created a new user with sudo permission.
After rebooting with Ubuntu i was able to login with the new user, but not the original root?

I am totally able to change the password.. at least it says?
I am getting "passwd: password updated successfully".

But when trying to login as root, i am getting "Access denied".

Anyway - i am just using the new user with sudo permission from now on.
Very strange problem - and not fully solved.

alvaroag
06-10-2015, 19:01
If you have Linux, you must reboot your server into rescue mode. From there, you can reset your root password with this commands:

mount /dev/sda /mnt
mount -t proc none /mnt/proc
mount --bind /dev /mnt/dev
mount --bind /sys /mnt/sys
chroot /mnt /bin/bash
passwd
(Here, you type twice your new password)
exit
umount -l /mnt/proc /mnt/sys /mnt/dev /mnt
reboot
If you have Windows, I think the Windows recovery has some option to reset the Administrator password.

BTW, remember OVH servers are unmanaged, and thus OVH has nothing to do with the server administration; password reset is part of the server administration.

FrederikC
06-10-2015, 17:26
Hello,

Any idea how i can reset the password for our dedicated server?
I did some updates, and after restarting the server, the password seems to have changed. We are not able to login.
We do not have any other accounts on the server, than the root.

We've contacted OVH support, but they haven't replied yet.
We've been waiting for 5 days already.

Any idea how I can fix this myself, without reinstalling the server?