We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

How to disable the OS firewal from KVM?


ServerSolutions
19-11-2016, 13:34
Quote Originally Posted by hobitron
Thank you for your help. none of the commands I'm entering in KVM is working. The KVM is stuck in SeaBios.
I can only enter commands in rescue mode but the server is still blocked.
My only hope now is at least to save my files but OVh dos'nt answer my request to get a backup of my files.
Which operating system you have installed on your server ? And what exact error are you getting in KVM with the iptables command ? You can attached screen shot here so that we can check that error message..

alvaroag
16-11-2016, 15:45
Then you don't have to disable it permanently, which is what I understood at first. You have a problem with your firewall configuration, which is blocking external access. Disable it from KVM, and then review the configuration so it doesn't happens again.

Remember KVM is not affected by firewall configuration, so it's a good channel to perform all firewall configuration tests without risking to loose access to the server.

Also, I'd recommend you to use some complete firewall solution, like firehol or shorewall.

Tecumseh
16-11-2016, 14:16
OVH is a unmanaged service provider, they have given you the tools to disable the software firewall with KVM and you can do so. Don't ask me as I have no idea but don't expect them to do it for you..

Unmanaged service provider means they give you the tools, you do the job. It's not part of their job to provide support with software issues.

hobitron
15-11-2016, 07:41
This is the exact message I got:
"Hello,

The firewall that is blocking your connection is a software firewall on your server. The OVH firewall is disabled and your server's software is blocking network access to the ports needed. This is why we recommended to connect through the KVM to fix the firewall on your server.

Since we are an unmanaged service provider, we only provide support for networking and hardware related issue, and any software issues need "

hobitron
15-11-2016, 07:39
Thank you for your help. none of the commands I'm entering in KVM is working. The KVM is stuck in SeaBios.
I can only enter commands in rescue mode but the server is still blocked.
My only hope now is at least to save my files but OVh dos'nt answer my request to get a backup of my files.

ServerSolutions
12-11-2016, 10:19
Login your server wth KVM and disable iptables with following command.

Code:
service iptables stop
If you have ubuntu on your server then try with below command.

Code:
sudo ufw disable

alvaroag
11-11-2016, 16:00
What exactly does the message says? OVH will never tell you to disable the firewall on a server.

BTW, how to do that depends on what OS you're using.

hobitron
11-11-2016, 11:29
Hi, my VPS is down for three days. I got an email from your support that I have to diable the OS firewall from KVM.
How can I do that?