We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Changed Port gone wrong


DigitalDaz
30-11-2016, 10:06
As has been said above, once in rescue mode it should be relatively easy to mount the hard drive if its not already mounted and then edit the original SSH config there.

My guess is that the original problem is that you probably have some sort of firewalling and though you have changed the SSH port you haven't dealt with the firewall.

Once recovered to the original state, you should be able to verify this with an: iptables -L

alvaroag
27-11-2016, 18:52
Reboot it into rescue mode from your Manager. There, you will be able to edit your sshd config.

Dylander
27-11-2016, 14:22
I have made a ticket about this if you were wondering and after 14 hours still no response

Dylander
27-11-2016, 14:21
Hey, I changed the port to access the server using nano /etc/ssh/sshd_config then changing 22 to 2421 then rebooted the server. I tried to log in with the old port and the new port but nothing was appearing, I tried common mistakes eg putting 2124 or 2221 but none worked. I need /etc/ssh/sshd_config put back to 22 or could you try find the port that it is on. The server IS running as when I put the ip into my browser it appears on the website I made for it. I just cannot connect. I have rebooted it in ssh once (before broken) then rebooted hard on panel twice.
I also used a port finder to see if I did make a mistake when typing and 2421 came up as filtered and 22 came up as closed.
Is there anyway to download the files on the system cause I don't mind reinstalling everything again I just need the data.
Otherwise is there a way to solve this.
Thanks, DyLander