We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

RPS Remote Desktop?


Bruno
29-03-2008, 12:45
Did you try to restart the nxserver ?

/etc/init.d/nxserver restart
/etc/init.d/nxclient restart

I know there is a problem if you create the user after... Does the directory .nx exist in /home/youruser/ ?

xUP
28-03-2008, 20:22
What file would it most likely be in if there is an error for NX server? I can try conencting again and then check the log. Is it possible an ovh tech can try get it working?

I used http://florianjensen.com/2007/12/31/...erver-with-nx/ btw

xUP
28-03-2008, 20:21
afaik i didn't see anything wrong in the logs but its pretty hard to read, some of those files are huge.

Bruno
28-03-2008, 19:13
syslog, messages, daemon.log, auth.log

xUP
28-03-2008, 19:09
Doubt its my computer, i don't have a firewall or anything.

apache2 debug fsck mail.warn syslog
apparmor dist-upgrade gdm messages syslog.0
apt dmesg installer mysql udev
aptitude dmesg.0 kern.log mysql.err user.log
auth.log dmesg.1.gz lastlog mysql.log wtmp
boot dmesg.2.gz lpr.log news wtmp.1
btmp dpkg.log mail.err oco
btmp.1 faillog mail.info pycentral.log
daemon.log fontconfig.log mail.log scrollkeeper.log

What one should I check?

Bruno
28-03-2008, 19:03
Did you check if it's not your firewall ??

Or the logs (/var/log) on the server ?

xUP
28-03-2008, 18:55
Done that, it connects, opens a big window with the nx logo in it, closes and popups a box saying:

The connection with the remote server was shut down.
Please check the state of your network connection.

Anyone know whats wrong?

Bruno
28-03-2008, 18:47
Quote Originally Posted by xUP
NX> 538 ERROR: User 'root' cannot be used as an NX user.P
You have to create a "normal" user :

Code:
adduser  myname

xUP
28-03-2008, 18:46
Installed and Started it:

NX> 203 NXSSH running with pid: 2780
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: **.**.***.** on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
/usr/bin/X11/xauth: creating new authority file /usr/NX/home/nx/.Xauthority
HELLO NXSERVER - Version 3.1.0-2 - LFE
NX> 105 Hello NXCLIENT - Version 3.1.0
NX> 134 Accepted protocol: 3.1.0
NX> 105 Set shell_mode: shell
NX> 105 Set auth_mode: password
NX> 105 Login
NX> 101 User: root
NX> 102 Password: ********
NX> 538 ERROR: User 'root' cannot be used as an NX user.
NX> 500 ERROR: Last operation failed.
NX> 280 Exiting on signal: 15

I need help, how do I fix it?

fozl
28-03-2008, 18:34
Yes, he can indeed...

But it's not ready set-up with Ubuntu server as it is Ubuntu desktop, likewise the other distros.

Bruno
28-03-2008, 17:04
Quote Originally Posted by fozle
It's running Ubuntu Server 7.10 though, not Ubuntu Desktop 7.04...
But he can install one :

http://florianjensen.com/2007/12/31/...erver-with-nx/

!

fozl
28-03-2008, 16:48
It's running Ubuntu Server 7.10 though, not Ubuntu Desktop 7.04...

xUP
28-03-2008, 16:21
Hi

I have an RPS but I can't connect with NX Windows Client, do RPS servers have this? if so, what can I do to fix it? The RPS is running Ubuntu