OVH Community, your new community space.

GeoIP - UK ip not a UK ip?


gregoryfenton
20-04-2009, 21:27
I am still having issues connecting to my server (virgin ftl)

I have found a workaround (web only, not shh)

Set your proxy to webcache.virginmedia.com port 8080

This works for me, ymmv.

Semi offtopic, but only follow the below if you are fully aware of the risks: (don't!)
I needed ssh access so I installed TOR (google) which worked but I wouldn't recommend it as it is unfortunately used by the more "shoot them in the head" element of the internet.

Sorry for the generalisation but it is not without just cause.

Andy
20-04-2009, 15:13
I doubt that would make much difference. My French IP was also blocked when I had issues. Its a routing issue into OVH altogether, nothing to do with the IP's.

AndiTails
20-04-2009, 14:37
Haha, fair enough. Good guess then...

Hmm, might need to shift my domains over the to french IP then, as its essentially 'blocking' access to the sites I host for VM customers

Andy
20-04-2009, 14:31
VM issue, OVH and VM are aware of it and have been for over a week, yet nothing has been done. Don't hold your breath either...

AndiTails
20-04-2009, 14:10
No, I gave up. The Ubuntu forums didn't help either.
VPN users always seen as French
Not the end of the world, just means no iPlayer during down-time

I did wonder if it was possible to make my box have the UK IP as the main IP, and the french one as the backup... But I didn't want to risk dropping it offline and causing more hassles really.

I've also had a problem where my UK IP seems to be 'dead' the past couple of days - but only for some people? Must be some muck-up on the backbone or something, as it can't be the server's setup if some people can connect and not others - and its dependant on ISP and/or location..

Most bizzare.

More likely as issue with Virgin Media or something like that - but why it only affects the UK IP I'm not sure..
(I'm on Virgin Media at home and can't connect to the UK IP, but from work and the office I'm sat in now on BT Broadband can all connect fine, so no idea!)

SteveTux
20-04-2009, 10:56
sn00k/Andi
Did you ever get this resolved? i.e. get your VPN users to identify themselves as uk-er's when they're on your vpn?

AndiTails
19-01-2009, 09:50
Why can CentOS do it without any problems then?
It's only in Gentoo, and now Ubuntu, that sees the IPs as one. Under CentOS I could differenciate accounts to different IPs.

There will be a way...

derchris
18-01-2009, 07:49
No, as these are all IPs, which are routed to your main IP

AndiTails
18-01-2009, 04:09
Guys - I'm happily running under Ubuntu now and its working lovely...

However, I'd like to get SSH running under the UK IP and not French, so when I SSH-Tunnel in, it will be seen as a UK surfer (so I get UK Google, etc).

This is my /etc/network/interfaces
auto lo
iface lo inet loopback
pre-up iptables-restore < /etc/iptables.up.rules

auto eth0
iface eth0 inet static
address 94.23.22.115
netmask 255.255.255.0
network 94.23.22.0
broadcast 94.23.22.255
gateway 94.23.22.254

auto eth0:0
iface eth0:0 inet static
address 87.98.254.123
netmask 255.255.255.255
eth0:0 being mapped to my UK IP. I did try changing eth0 and eth0:0 round, but made no difference.

So then had a look in /etc/ssh/sshd_config
And put:
ListenAddress 87.98.254.123

But when I restart sshd, I can't connect at all... (Luckily I didn't close the initial connection, so I could log back in to undo that!!)

So, can I either:
  • create a single SSH user that is binded to eth0:0
  • make the whole server work off the UK IP


Thanks, all.

AndiTails
16-01-2009, 09:52
Sounds like the VPN (or SSH login, however you're doing it) is bound to just the French IP?

I know when you create accounts in other Linux distro, it asks what IP to bound it to. And Gentoo doesn't do this, so perhaps that's the issue?

sn00k
15-01-2009, 17:20
Quote Originally Posted by fozle
This strikes me as a VPN issue to be fair. I know my colleague's replied to an email you sent though so best to go by his recommendation.
Hi Fozle.
I'm not sure how this counts as a 'VPN issue'.

As I said: I'm trying to have the additional UK IP bound as the IP for any VPN clients.

Connecting to the original french IP - there's no problem.
Connecting to the UK IP - everything proceeds to the point of Authentication, before it stalls and disconnects.

I've scoured google + IRC for information on what could be causing this, or what can be done to resolve this.

Your colleauge's email, unfortunately, was frankly, was of no help whatsoever:
I am unsure what you mean by 'VPN Clients' please can you explain what you are exactly trying to do with VPN? Have you looked at Google for advice or guides?

You have full root access to the server so you should have no problem in trying to accomplish.
I had been explicitely told by pre-sales staff that having the VPN go through / being bound to the UK IP would be no problem at all.

Now, I'm presented with support that tells me they're:
A) Not familiar at all with the product they're selling

and

B) To solve the issue myself.

I understand that OVH doesn't provide a fully managed service - with that said though, I'd expect a vague minimum of support - or the option to pay to have the task done.

I've had many, many boxes in my time, managed and unmanaged, but I've never struck an issue such as this..

Your advice would be appreciated.

fozl
15-01-2009, 16:23
Quote Originally Posted by sn00k
I've got the same problem with my box [Gentoo - Extranet Group Work]
I specifically need / want a UK IP for this box.

I requested one, and added it as the IP Alias [eth0:1]

So - when I VPN [PPTP] to the original IP - it connects and works, no worries.
When I VPN to the new IP - it connects, but fails on authentication.

I've tried for the life of me to find out how to bind the VPN IP to the new one, or as to why the login is failing.

Emailed support, as I was promised in pre-purchase that I'd be able to use a UK IP with no worries for the VPN - but still no response..

Any ideas?
This strikes me as a VPN issue to be fair. I know my colleague's replied to an email you sent though so best to go by his recommendation.

fozl
15-01-2009, 16:21
It's because outgoing connections from ovh servers are always done so as the static, that's why the tool reports the static IP.

If you reverse a domain hosted on your server to the IP failover however, that site will be listed as geolocalized (to the UK in this case).

mastens
15-01-2009, 15:41
Hi, i would not trust mapmyip.com, because it tells me im sitting in PT, with the ip i have, and it cleary stats which country and city i am sitting in, and that's not even close to PT.

So, www.mapmyip.com are not trustable.

sn00k
15-01-2009, 15:08
I've got the same problem with my box [Gentoo - Extranet Group Work]
I specifically need / want a UK IP for this box.

I requested one, and added it as the IP Alias [eth0:1]

So - when I VPN [PPTP] to the original IP - it connects and works, no worries.
When I VPN to the new IP - it connects, but fails on authentication.

I've tried for the life of me to find out how to bind the VPN IP to the new one, or as to why the login is failing.

Emailed support, as I was promised in pre-purchase that I'd be able to use a UK IP with no worries for the VPN - but still no response..

Any ideas?

fozl
15-01-2009, 15:03
Well your IPf is ultimately routed to your static IP, I guess that's why you see the static IP information when you go to mapmyip.com, how they do that I don't know.

Do you have any sites using the UK IPf and are (somehow) listing as French?

AndiTails
15-01-2009, 12:14
From work, I use entunnel, which uses a SSH session to the server, and I set the SOCKS proxy on my browser to go via enTunnel, so I can browse the full net, via the server.

My UK IP is 87.98.254.123, and the account I'm SSH'ing via is bound to this - but sites I visit don't see this IP (perhaps as on the same adapter - a flaw in Gentoo?), so mapmyip says (interestingly):

Your computer's IP address is:
94.23.22.115

Your computer's hostname is:
ns366994.ovh.net

Your location is:
(Unknown City?), (Unknown Country?) (XX)


So why doesn't it know where my french IP is either!?! Oops!

fozl
15-01-2009, 10:30
Ok, but before you do just so I can investigate this and see where the error is, can you send us/post up a screenshot of what you see on mapmyip.com from the server.

By the way are you using links/linx or have you setup an NX server or something?

AndiTails
15-01-2009, 10:19
Because your instructions said not to do that with Gentoo

It's ok, I'll be changing to Ubuntu tomorrow and will figure out how to do a virtual adapter on that

fozl
15-01-2009, 09:54
Why not bind it to a virtual adapter like eth0:0?

AndiTails
13-01-2009, 10:19
My nic is ta14237-ovh

Many thanks.

fozl
13-01-2009, 10:18
What's your nic please? Or contact us directly with the nic and (if you have more than one) the server in question.

AndiTails
12-01-2009, 13:44
Hi.

I got a fallback IP for my server, which I use for showing a UK site being an actual UK site, but also because I use a SSH Tunnell at work to the server, which under CentOS was fine - I'd get UK Google, etc.
But now I've moved to OVH Release 2 Gentoo, I think because the IP is binded to eth0 along with the normal IP (not a secondary adapter, like eth0:0) I now get Google France, etc...

Also, doing 'map my IPs' etc - they all show the IP now being in France.
But RIPE still say its a UK IP...?

(OVHm is blank in the country column for the IP, which concerns me too).

Anyone any idea:
a) what I'm on about!
b) how I can be a UK'er again?