OVH Community, your new community space.

Problem installing VMWare Server on Debian 4.0


PeterUK
09-03-2009, 11:55
I also made a very detailed guide on installing VMWare for Ubuntu, I don't imagine it would be very different for your situation.

http://forum.ovh.co.uk/showthread.php?t=933

sama
09-03-2009, 00:53
thanks a lot, that was very useful. to add, this also came very handy:

http://translate.google.co.uk/transl...hl=en&ie=UTF-8

thanks

DigitalDaz
08-03-2009, 20:32
You may find this thread useful:

http://forum.ovh.co.uk/showthread.php?t=239

sama
08-03-2009, 03:48
Hi There

I'm trying to move my vm's from another box that is currently running vmware 2.0, so it's essential that I install that.

I've tried the following so far:

1. downloaded the latest vmware server from their site and unpacked it
2. unpacked the src files under /usr/src/linux-2.6.28.1-xxxx-vmware-ipv4-32/include/
3. typed the following:
cd /usr/src/linux-2.6.28.1-xxxx-vmware-ipv4-32
cp /boot/config-2.6.28.4-xxxx-vmware-ipv4-32 .config <<< I didn't realise I made this mistake when I did it, I just clicked tab and assumed it was the version!
make
4. I created an ln -s /usr/src/linux-2.6.28.1-xxxx-vmware-ipv4-32 /usr/src/linux
5. ran the vmware-install.pl script

and it gets to the part where it needs to says:

None of the pre-built vmmon modules for VMware Server is suitable for your
running kernel. Do you want this program to try to build the vmmon module for
your system (you need to have a C compiler installed on your system)? [yes]

Using compiler "/usr/bin/gcc". Use environment variable CC to override.

What is the location of the directory of C header files that match your running
kernel? [/usr/src/linux/include]

The directory of kernel headers (version 2.6.28.1-xxxx-vmware-ipv4-32) does not
match your running kernel (version 2.6.28.4-xxxx-vmware-ipv4-32). Even if the
module were to compile successfully, it would not load into the running kernel.
it seems the src's included in the distro don't actually match the running kernel.

any idea where I can get the matching src from?

Thanks for any help.

Sama

kro
16-02-2009, 12:18
eKKiM wrote:
> Can someone please help me?


You could try the ready-to-use Vmware Distribution - it's just that: Debian
etch with VMware server 1.0.8 and an adapted kernel, sources are included.

Best regards,
Felix
--
Felix
OVH Team

derchris
14-02-2009, 17:17
You need to get another kernel.
OVHs kernel is not modular.

eKKiM
14-02-2009, 13:03
Hi

i can't find the kernel header files for my debian..
Can someone please help me?

When i run installer i get this error
Code:
/var/vm/vmware-server-distrib# ./vmware-install.pl
WARNING: Couldn't open directory /lib/modules/2.6.24.5-grsec-xxxx-grs-ipv4-32: No such file or directory
FATAL: Could not open /lib/modules/2.6.24.5-grsec-xxxx-grs-ipv4-32/modules.dep.temp for writing: No such file or directory
Unable to open kernel module dependency file
.Execution aborted.