OVH Community, your new community space.

HOWTO: forward ports under VMWARE with WindowsXP as guest


freshwire
16-03-2009, 16:16
Yes this was the easy bit for me ^

However I had it under [IncomingTCP] rather than the UDP as said above.

derchris
16-03-2009, 00:12
I think you are missing the point.
NAT was never a problem, but rather not acceptable from a Customers point of view.
What the majority had problems with is getting the Host-only netowrking to accept connections from inside/outside with the Failover IPs, as Bridge mode is not working because of this "crappy" network configuration they are using.

I think NAT is is good documentaed, but thanks anyway.

luc1f3r
15-03-2009, 22:39
Okay, i know alot of people having problems forwarding ports under vmware with windows xp running as guest. Finally solved the problem.
To all you people who are still struggling.
This might be the guide....


To forward ports for windows running as guest under Debian vmware.


  • login with any good ssh client to your box
  • grab the file /etc/vmware/vmnet8/nat/nat.conf
  • open the file in an editor lets say SCiTE
  • add the ports =hostort to the [incomingUDP] area. *
  • then restart the network services.
  • type /usr/lib/vmware/net-services.sh restart
  • in windows type goto start --> run --> ipconfig /renew to apply settings.


* for example,
#(port) = (local adres here)port)