We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Server IP Address


freshwire
29-04-2009, 14:49
Debian is insanely stable

SteveTux
29-04-2009, 13:53
Ok thanks, I'll give it a shot.
I'm leaning towards a Debian install now - CentOS was only my first choice because I'd picked that one first. But I'd noticed that a lot of times after rebooting an OVH CentOS server (by typing reboot at terminal) it would often hang and I'd need to go to the vmanager to reboot it. Could be something that I'd broken of course

Ashley
29-04-2009, 09:29
What I tend to do on my Debian Etch 4.0 configuration is add my fail over IP's as virtual interfaces to eth0. So for example, eth0:0 is 87.98.254.249 and eth0:1 is 87.98.254.250 etc.

Then if I need a specific program to run on a specific ip, 9 out of 10 times there is the option to BIND to an IP. This is where the program will run on and listen to incoming data to that IP only. Any data then sent to the internet from this IP will also be shown as coming from this IP address.

You can bind apache, mysql, mailservers, irssi etc to their own IP addresses.

SteveTux
27-04-2009, 16:21
ok thanks - but you're saying it IS possible to connect to my server and have its outbound traffic to the web go through the UK IP and not the french one.
thanks

fozl
27-04-2009, 16:05
Either you can get involved in source-based routing (I don't advise it on the RPS as you could screw up your connection to the SAN, OCO or the normal Ovh monitoring) or just configure the service you want. We can't offer support on either of these options though.

SteveTux
27-04-2009, 15:16
Hi Fozle

Thanks for your reply. Is there a way to configure that static outgoing IP to be the uk IP?

fozl
27-04-2009, 14:46
The static IP is always the outgoing one, your domains hosted using the IP failover are reported with the geolocalization requested for the IPf, and provided you've configured your email server correctly, shows the IPf in email headers so your emails don't get spam-filtered.

SteveTux
27-04-2009, 13:16
Are there any default gateway or default router settings I need to adjust anywhere?

SteveTux
27-04-2009, 11:03
Oh my god I have tried and tried and tried with this – with absolutely no result. monkey56657 are you able to shed ANY more light or help me out with the quick step by step?

I’ve tried it under Centos, Ubuntu Server 8.0.4 LTS and Ubuntu desktop with ovh’s link http://help.ovh.co.uk/IpAlias And although YES I can set up the aliases in the networking options – I cant force the box to go out to the net with the UK IP. www.mywaip.com ALWAYS resolves to that 94.x.x.x French IP.

If I do a whois on the uk ip, then yes it shows as uk registered – but I just cant get the box to identify itself to websites as from UK

Also connecting over vpn (and all traffic through vpn) all clients still identify to the web as 94.x.x.x 

Forcing eth0 to take the UK IP instead doesn’t work either – it just makes the machine unreachable.

PLEASE is there anything obvious I’m messing up here?

freshwire
21-04-2009, 16:58
You can modify /etc/network/interfaces at any time. Just run /etc/init.d/networking restart afterwards.

SteveTux
21-04-2009, 14:15
Cool thanks. What advantages do you get using the vKVM method? Is it just because you get to configure everything on install presumably?
At what point do you do the eth0 ip switch - after install completes I take it?

freshwire
21-04-2009, 13:00
Ubuntu Server 8.04 LTS (installed using vKVM).

Debian etch also has the same result.

SteveTux
21-04-2009, 09:40
Hi Monkey, what install of Ubuntu you using - or does it not make any odds?

freshwire
20-04-2009, 23:45
Quote Originally Posted by SteveTux
Hi Monkey
Thanks for your post - so your saying update eth0 with your uk IP and then put the others in as eth0:0, eth0:1 etc. and uk IP works?
I'll have a bash
That principal works for me yes.

SteveTux
20-04-2009, 20:48
Hi Monkey
Thanks for your post - so your saying update eth0 with your uk IP and then put the others in as eth0:0, eth0:1 etc. and uk IP works?
I'll have a bash

freshwire
20-04-2009, 19:03
Simply by having the IP of choice as eth0 and all other IPs as eth0:0 eth0:1 etc should suffice.

At least this works perfect on debian/ubuntu.

SteveTux
20-04-2009, 15:44
I did contemplate this actually - although I'm beggining to wonder if it is actually possible or not fullstop? Because any alias like eth0:0, eth0:1 etc. are essentially just that arent they; just alisases/shortcuts to the main ethernet card - which then goes out to the net on its own ip..?
I dunno, wondering if I'm flogging a dead horsie....

Akd
20-04-2009, 13:33
With e.g. squid you can bind outgoing traffic to an IP:

tcp_outgoing_address *.*.*.* all

Assuming you have an "all" ACL defined.

.. by default your traffic will pass through the "main" interface .. so you'll have to manually bind your applications to whatever interface/IP you want the output/input through.

Assuming you have eth0 as your main interface with your default IP .. then using virtual interfaces above that e.g. eth0:0 eth0:1 for your additional IPs.

Might be able to swap so that you have your UK ip on eth0.

Might even be able to have a squid proxy running and then tunnel the VPN through that?

Regards,
Akademien

SteveTux
19-04-2009, 17:35
No worries
I'm re-installing the OS now and will start from scratch - see if I've not bodged something up along the way

Andy
19-04-2009, 17:11
Like I said, if you want to have Google see it as a UK based server, then only the one attached to the domain matters. The outgoing data can use any IP. But if you really want it to use that one, there must be a way. Unfortunately, I don't know it

SteveTux
19-04-2009, 17:09
Theres no domain there at the mo, its just a test environment. I'm not worried about that side, its the other side - the outgoing data. Thats where my problem lies, I'm trying to tell the box to use the UK IP when it goes out anywhere - but to no avail (yet!)

Andy
19-04-2009, 17:03
Well to use your UK IP, just point your domain to that IP. Google etc will then see it as UK based. Outgoing data can be on any IP, it doesn't matter.

SteveTux
19-04-2009, 16:52
Hehe nah not quite, I wish! What I've got is:
Main IP: 87.98.129.x
Failover IP: 94.23.43.x
UK IP: 87.98.250.x

Despite what I try, all wan ip websites show the french 94.23.43.x one

I'm trying to use IPTABLES to route traffic to that uk ip, doesnt seem to be doing much tho

Andy
19-04-2009, 16:17
Well your fail-over IP is the UK based one. The main IP will be geographically located in France. So in fact, its working just how you need it to

SteveTux
19-04-2009, 16:14
I just wondered why it was doing it. I've got a UK IP that I've 'bought'/renting through ovh. I wanted to have a vpn and push all traffic out through that UK IP so that if I dial in then I uk google etc.

Andy
19-04-2009, 16:00
The manager won't change anything on the server. It doesn't actually matter that its using the fail-over IP as the outgoing IP, unless you specifically wanted to use the main IP for some reason?

SteveTux
19-04-2009, 15:58
I'm no linux guy either - just messing around with it. Its quite fun tbh, just takes longer to solve problems tho :/
I think its just using the failover as the main ip - is there something that you can change in the ovh web manager? There is a failover option in there - but cant really work out what it does.. ?

Andy
19-04-2009, 13:17
Ah in that case I can't help. I'm not a Linux guy.

Is there any way to "order" the IP's you have configured? Maybe the top IP or the last one you added is the one is uses as the default? I have no idea, I'm making wild guesses here.

SteveTux
19-04-2009, 13:13
Hi Andy
Its Centos, and I've not configuered it to do anything fancy. I'm happy to pm you screenshots of stuff if you tell me what and where?

Andy
19-04-2009, 10:45
I get the main IP on mine... What is your OS and how did you configure the fail-over IP?

SteveTux
19-04-2009, 09:14
Hi guys
If I get onto my server and goto www.mywanip.com , the IP address I get there is the failover ip (the 94.23.x.x one)

Surely it should be the main IP thats listed there? How can I get that back?