OVH Community, your new community space.

NoMachine - cannot login after creating new user!


boxfive
01-05-2009, 01:23
Tell me about it. Sometimes you just get so caught up in figuring out the complicated crap you totally miss the obvious

Ashley
30-04-2009, 17:15
Quote Originally Posted by boxfive
Fixed! Really basic problem too. The dir /home/jstone was owned by root. Running $ sudo chown -R jstone:jstone /home/jstone fixed it.

Obviously the client was trying to write the session info to the directory and failing miserably because of the permissions issue.
Schoolboy error

boxfive
29-04-2009, 22:55
Fixed! Really basic problem too. The dir /home/jstone was owned by root. Running $ sudo chown -R jstone:jstone /home/jstone fixed it.

Obviously the client was trying to write the session info to the directory and failing miserably because of the permissions issue.

boxfive
29-04-2009, 22:27
[solved]

Hey guys,

Would greatly appreciate any ideas you can throw out about this.

I installed Ubuntu 8.04 Desktop on my new EG AMD, but never though I'd have an easier type disabling RAID1 than adding a new user to login via NoMachine's NX client.

The default admin user logs in fine, no issues there. However I added a new user, jstone, and I just can't get the bloody client to start a proper session with that login.

The user was added via the shell's 'useradd' and can SSH into the server just fine.

Here's the log from NoMachine's Windows NX client.

Code:
NX> 203 NXSSH running with pid: 3108
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address:  on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
HELLO NXSERVER - Version 2.1.0-72 OS (GPL, using backend: 3.2.0)
NX> 105 hello NXCLIENT - Version 2.1.0
NX> 134 Accepted protocol: 2.1.0
NX> 105 SET SHELL_MODE SHELL
NX> 105 SET AUTH_MODE PASSWORD
NX> 105 login
NX> 101 User: jstone
NX> 102 Password: 
NX> 103 Welcome to: ns###.ovh.net user: jstone
NX> 105 listsession --user="jstone" --status="suspended,running" --geometry="1440x900x32+render" --type="unix-gnome"
NX> 127 Sessions list of user 'jstone' for reconnect:

Display Type             Session ID                       Options  Depth Screen         Status      Session Name
------- ---------------- -------------------------------- -------- ----- -------------- ----------- ------------------------------


NX> 148 Server capacity: not reached for user: jstone
NX> 105 startsession  --link="adsl" --backingstore="1" --encryption="1" --cache="16M" --images="64M" --shmem="1" --shpix="1" --strict="0" --composite="1" --media="0" --imagecompressionmethod="4" --imagecompressionlevel="6" --render="1" --session="ovh" --type="unix-gnome" --geometry="1280x720" --client="winnt" --keyboard="pc102/en_US" --screeninfo="1280x720x32+render" 

NX> 1000 NXNODE - Version 2.1.0-72 OS (GPL, using backend: 3.2.0)
NX> 280 Exiting on signal: 15
I must say I'm a bit dumbfounded. I see no errors or anything that could explain the 'Connection Timeout' I'm getting. Any ideas? Anyone? Bueller?