OVH Community, your new community space.

CURL & Port 8080


eebahoo
28-05-2009, 10:26
Got my response - 8080 is blocked on shared hosting.
I have had to upgrade to an RPS.
Thanks for your help!!

eebahoo
28-05-2009, 09:11
Sorry I forgot to mention - the other server has a firewall, which makes it difficult for anyone other than me to test (or anyone with the same plan90 IP I guess). It blocks incoming calls from everywhere other than "allowed" IP's. That would explain why you can't see it. (monkey56657)

I took the quotes off the port with no luck - same response. (Myatu)

I also tried via fsockopen but that wont allow it either.

I have contacted support but I'm still awaiting a response.

freshwire
27-05-2009, 20:25
On port 8080 for me the connection times out. No message at all.

Myatu
27-05-2009, 19:43
Take out the quotes?
Code:
curl_setopt($ch, CURLOPT_PORT, 8080);

eebahoo
27-05-2009, 19:25
Hello,
I know what you mean but "KO: Null parameter" is a valid response. On port 80 you get a 404.

http://213.27.137.219:8080/SMSGatewa...teway2Listener (OK)
http://213.27.137.219:80/SMSGateway/SmsGateway2Listener (NOT OK)

CURL seems to give the 80 response.

Cheers
Jim

freshwire
27-05-2009, 19:23
It isn't loading on 8080 for me

eebahoo
27-05-2009, 18:53
Hello,
I am trying to connect to another server from OVH using CURL (PHP) on port 8080.
Script is:

PHP Code:
curl_setopt$chCURLOPT_URL'http://213.27.137.219/SMSGateway/SmsGateway2Listener' );
curl_setopt$chCURLOPT_PORT'8080' );

curl_exec$ch ); 
If you visit the address: http://213.27.137.219:8080/SMSGatewa...teway2Listener it works fine and returns correct response.

CURL seems to be sending via port 80. Does OVH disable port 8080 connections? I have a 90plan if that helps.

Any help would be appreciated!
Thanks
Jim