OVH Community, your new community space.

Network Configuration


TylerGlobal
09-06-2009, 20:40
Well vKVM doesn't work, when I try to reboot the server into rescue mode that hasn't been working either, so I guess I'll just use the server for the rest of the month on ovh's distro and raid 1.

freshwire
09-06-2009, 05:16
Try 'rescue-pro' netboot instead.

mount the drive, then fix grub.

TylerGlobal
09-06-2009, 04:48
Well yes if anyone knows why I'm getting this Java error that would be great.. so I don't spend all this money for a broken server, since I can't really do much till I get the boot partition set.

TylerGlobal
07-06-2009, 06:21
Well I considered this, but I recently tried booting from an ISO too which will not work either, so OS should have no effect on that. :/

Neil
07-06-2009, 00:29
Quote Originally Posted by TylerGlobal
I did do a hard reboot.

But I think I have figured out the problem. when I did the install I setup a custom partition system that I found to be much more efficient, and also set it up with raid 0 instead of 1, since I'm not storing extremely important data on here. But since I set it up manually, Fedora most likely never set a partition as the primary boot partition, which might explain the grub issues.

But aside from this, thanks Neil for getting the server up for me I have attempted to put it back into vkvm mode and modify the partitions again to get the boot working, but vKVM hasn't been working for me since I have done the main install. I get the error "Network Error: RSA premaster secret error" I have no idea why I'm getting this, but since you've been so helpful already Neil, any ideas?
Hi, the error is a Java related error, so it could be numerous related issues. But I have a feeling it is to do with the OS you have now installed is now experiencing problems were working with vKVM (Maybe the OS is not even bootable in vKVM) and is not at all a Java error itself.

TylerGlobal
06-06-2009, 08:21
Quote Originally Posted by monkey56657
Doesn't "Hard Reboot" also turn it on? I think it does... My friend accidently shutdown my server in the past :P
I did do a hard reboot.

But I think I have figured out the problem. when I did the install I setup a custom partition system that I found to be much more efficient, and also set it up with raid 0 instead of 1, since I'm not storing extremely important data on here. But since I set it up manually, Fedora most likely never set a partition as the primary boot partition, which might explain the grub issues.

But aside from this, thanks Neil for getting the server up for me I have attempted to put it back into vkvm mode and modify the partitions again to get the boot working, but vKVM hasn't been working for me since I have done the main install. I get the error "Network Error: RSA premaster secret error" I have no idea why I'm getting this, but since you've been so helpful already Neil, any ideas?

Neil
05-06-2009, 12:44
Quote Originally Posted by monkey56657
Doesn't "Hard Reboot" also turn it on? I think it does... My friend accidently shutdown my server in the past :P
Yes it does turn it back on, but if monitoring is on an intervention will also made and the server will be turned back on.

freshwire
05-06-2009, 12:41
Doesn't "Hard Reboot" also turn it on? I think it does... My friend accidently shutdown my server in the past :P

Neil
05-06-2009, 10:48
Quote Originally Posted by TylerGlobal
Well that new info should help

But unfortunately, the server will no longer boot into either rescue mode or vKVM, and I am constantly being flooded with emails saying technicians are being sent out to inspect it. vKVM and rescue mode should be separate from my Fedora installation so now I'm not sure what the problem is...
Hi

I have looked at the server and see it appears to be offline, but no intervention has been scheduled to correct this, so I have opened an Incident ticket

TylerGlobal
05-06-2009, 05:18
Well that new info should help

But unfortunately, the server will no longer boot into either rescue mode or vKVM, and I am constantly being flooded with emails saying technicians are being sent out to inspect it. vKVM and rescue mode should be separate from my Fedora installation so now I'm not sure what the problem is...

Neil
04-06-2009, 11:21
Hi

The last intervention log yesterday morning indicated there was a problem with booting as the server was prompt was 'grub>' .

It is possible to do it through vKVM (although I have not seen it done with Fedora), google is also a very good friend ;-), http://www.google.co.uk/search?q=ovh...ient=firefox-a

TylerGlobal
04-06-2009, 03:33
I just turned off monitoring so it won't throw it into rescue mode any more.

And as far as I know it doesn't and should not have a problem booting, since it is a fresh install and I have watched it start OVH kernel to no avail. And if there is an issue with booting, or anything else for that matter, I have extensively checked logs and there is nothing indicating that the server cannot boot or acquire internet access.

freshwire
03-06-2009, 23:19
Sounds more like a problem booting rather than network problem. Specially if you can access ovh network from the vKVM.

Andy
03-06-2009, 22:55
You can turn off monitoring under:

Administration > Server State > Monitoring > Stop

That should stop it putting you into recovery mode.

EDIT: Forgot to mention vKVM does stop internet access on Linux.

TylerGlobal
03-06-2009, 22:37
Yes I have, whenever I boot from the hard drive without vKVM, I get an alert saying the server has stopped replying to pings and it automatically goes into recovery mode.

freshwire
03-06-2009, 22:28
I don't know for sure... but have you tried without the vKVM? Maybe that is the limiting factor.

TylerGlobal
03-06-2009, 20:59
I recently installed Fedora 10 x86_64 on my server without problems through vKVM. Since I used the default Fedora ISO, it was not installed with the OVH scripts, patches or kernel, which was the intention.

Although I have been having one problem with it, it cannot connect to the internet outside of OVH. Here is my current configuration:

/etc/sysconfig/network-scripts/ifcfg-eth0
Code:
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=static
IPADDR=94.23.205.132
NETMASK=255.255.255.0
GATEWAY=94.23.205.254
/etc/sysconfig/network
Code:
NETWORKING=yes
HOSTNAME=box01.tylerglobal.org
/etc/hosts
Code:
127.0.0.1 localhost.localdomain localhost
94.23.205.132 box01.tylerglobal.org box01
/etc/resolv.conf
Code:
#OpenDNS
nameserver 208.67.222.222
nameserver 208.67.220.220
Note: box01.tylerglobal.org points to my server, and is also the reverse DNS for it's IP.

Unfortunately I cannot provide more information since vKVM has stopped working for me, but this appears like it should be working to me, and I also compared it to the configuration from another fedora user at OVH. So if anyone else could figure out whats going on that would be great.