OVH Community, your new community space.

Promox IP routing


Tipika
14-05-2010, 15:26
Quote Originally Posted by Myatu
Perfect! Very useful!

makno
12-05-2010, 23:07
uhm i got windows to get the ip simply adding the network card in the proxmox panel with the mac address that was binded to that ip. nothing added on the host, just set the guest network to have static ip and regedit the network mask. windows (guest) is using a failover ip as i think that's what you're trying to do

ictdude
12-05-2010, 21:20
Mmmmh did you check if you can ping a IP adress ? So not a dns name but
only the direct adress ? Maybe DNS problems ? Can you ping the gateway ?

I had a dns issue could ping dns but resolving no go...

Myatu
12-05-2010, 17:24
Try these:

http://www.myatus.co.uk/2009/08/31/g...-with-proxmox/
http://www.myatus.co.uk/2010/03/20/g...ending-its-us/

The ovhwiki website seems to be defunct.

Tipika
12-05-2010, 16:34
Quote Originally Posted by Myatu
I've just posted a new article on the ovhwiki
It's a long time that that page is offline, is it normal?

edit: I used that awesome guide last year to set my server, I need to read it another time :P

gigabit
09-07-2009, 00:01
Wow thanks! Really good guide!

Another thing, have you noticed abnormally high CPU usage with windows in your virtual environment? Im using 2K3 and I was downloading an ISO and CPU was about 30% and i thought it was really high - the virtual machine has been assigned 2 CPUs (2.83Ghz xeons) so i'm a bit stumped... is there maybe a lot of overhead because its a guest OS or something?

Edit: got process explorer, seems to be "hardware interupts" and "defered procedure calls", time to investigate...

Edit 2: remounted the drives as SCSI and things got better - not great, but better.

Myatu
08-07-2009, 03:09
Personally I have not had that much luck with the bridged veth network intefaces (venet is fine) and have resorted to using DNAT/SNAT instead.

I've just posted a new article on the ovhwiki (http://ovhwiki.com/index.php/Firewal...r_with_Proxmox) which is based on my own setup, and I know for a fact that this will work with Windows (I use Windows 7 RC 1).

gigabit
07-07-2009, 17:30
I just can't figure this out! People have reported it works but i just cant figure it out!

Im using the "ready to use" Proxmox distro from OVH i just installed.

I've then installed Windows 2003 as a guest OS, then set up my failover IP under "network connections", then did the whole regedit thing to fix the netmask.

So Windows is set up right, but i can't get the IP from the host to the guest...

I've tried everthing - posts on the forum, the ovh help guides... I then just tried all combinations of NAT and the bridge with adding a "route" etc etc, but Windows just cant access the outside world.

I've undone any network edits i did, back to the defaults (shown below) - can someone please give me steps as to what i need to do?

In Poxmox "interface configuration" is:
Code:
eth0	yes			94.23.196.xxx	255.255.255.0	 
vmbr0	yes	dummy0		94.23.196.xxx	255.255.255.0
(yes, the IPs are the same (the main IP for the server, not failover). it came set up that way)

"route" prints out:
Code:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
94.23.196.0     *               255.255.255.0   U     0      0        0 eth0
94.23.196.0     *               255.255.255.0   U     0      0        0 vmbr0
default         94.23.196.254   0.0.0.0         UG    0      0        0 eth0
my /etc/network/interfaces file
Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
        address 94.23.196.xxx
        netmask 255.255.255.0
        network 94.23.196.0
        broadcast 94.23.196.255

        gateway 94.23.196.254

auto vmbr0
iface vmbr0 inet static
        address 94.23.196.xxx
        netmask 255.255.255.0
        post-up /etc/pve/kvm-networking.sh
        bridge_ports dummy0
        bridge_stp off
        bridge_fd 0
And for good measure - windows TCP/IP settings:


Thanks!