OVH Community, your new community space.

DNS How to?


freshwire
21-07-2009, 01:55
I use a local dns cache/resolver. No delays at all

Andy
20-07-2009, 19:58
Quote Originally Posted by everwicked
Thanks Neil, I guess I have to wait for Virgin to refresh their cache.
Or change your DNS to OpenDNS then use their cache updater to do it yourself

everwicked
20-07-2009, 18:19
Quote Originally Posted by Neil
Yep, looks fine and it resolves for me http://visumalchemia.com, just need put files in the Apache directory.
Thanks Neil, I guess I have to wait for Virgin to refresh their cache.

Neil
20-07-2009, 18:08
Quote Originally Posted by everwicked
This is the config for the domain:



Does this look correct? The refresh time is set low on purpose for the time being.
Yep, looks fine and it resolves for me http://visumalchemia.com, just need put files in the Apache directory.

everwicked
20-07-2009, 18:04
This is the config for the domain:

visumalchemia.com. IN SOA ns1.visumalchemia.com. admin.visumalchemia com. (
1248095938
300
3600
1209600
38400 )
visumalchemia.com. IN NS ns1.visumalchemia.com.
visumalchemia.com. IN A 91.121.180.10
visumalchemia.com. IN NS ns2.visumalchemia.com.
www.visumalchemia.com. IN CNAME visumalchemia.com.
mail.visumalchemia.com. IN A 91.121.180.10
visumalchemia.com. IN MX 1 mail.visumalchemia.com.
ns2.visumalchemia.com. IN CNAME ns.kimsufi.com.
ns1.visumalchemia.com. IN A 91.121.180.10
Does this look correct? The refresh time is set low on purpose for the time being.

everwicked
20-07-2009, 17:36
Alright guys, I gave this a shot with webmin...

http://pingability.com/zoneinfo.jsp?...umalchemia.com seems to be giving my good news but I can't resolve the hostname from my home PC just yet - perhaps it's a propagation issue, I have to wait a bit.

DedicatedPros
20-07-2009, 17:29
I thought about using Webmin myself, but the web interface seemed a little poor, Plesk is only good when its free as its pretty much feature less, and cPanel is very good but also pricey (ie. there is no 10 domain license, just unlimited)

Neil
20-07-2009, 17:17
Quote Originally Posted by DedicatedPros
That's not binding a nameserver mate, its binding a domain, which means adding the domain to a server, otherwise the connection will drop.

You cannot use a server without binding a domain, but panels such as cPanel/Plesk/Webmin/LXAdmin make this painfully easy, I recommend you reinstall the server with Plesk (free 1 domain license for all Kimsufi servers).
Yes, also we do offer Release 2 which has Webmin installed and you can also install your own control panel on Ubuntu.

DedicatedPros
20-07-2009, 16:50
That's not binding a nameserver mate, its binding a domain, which means adding the domain to a server, otherwise the connection will drop.

You cannot use a server without binding a domain, but panels such as cPanel/Plesk/Webmin/LXAdmin make this painfully easy, I recommend you reinstall the server with Plesk (free 1 domain license for all Kimsufi servers).

everwicked
20-07-2009, 14:49
Quote Originally Posted by Neil
I see your server is running Ubuntu Desktop, you will need to bind the domain to the server, http://help.ovh.co.uk/ManualBindServer or Install a control panel that will do all this automatically.
Hehe - I thought this configuration did not require a binding nameserver!

Is there a configuration to go with Ubuntu that will work without bind?

Neil
20-07-2009, 10:58
I see your server is running Ubuntu Desktop, you will need to bind the domain to the server, http://help.ovh.co.uk/ManualBindServer or Install a control panel that will do all this automatically.

DedicatedPros
20-07-2009, 10:22
Are you sure you've added the domain properly on the server?

Also by any chance have you been messing around with the server side settings of your hostname/IP? There seems to be some kind of issue there

everwicked
20-07-2009, 00:36
Quote Originally Posted by DedicatedPros
You have to login to the manager, choose your server, go to Services > Secondary DNS > New Domain and add visumalchemia.com
visumalchemia.com 2009-07-19 23:31:30 91.121.180.10 ns.kimsufi.com ACTIVE

Still doesn't resolve

DedicatedPros
19-07-2009, 23:57
You have to login to the manager, choose your server, go to Services > Secondary DNS > New Domain and add visumalchemia.com

everwicked
19-07-2009, 23:04
Thank you gentlemen - I've done what you said but it doesn't seem to work...

From whois visumalchemia.com:

Domain servers in listed order:
KS363457.KIMSUFI.COM
NS.KIMSUFI.COM
admin@ks363457:~$ nslookup visumalchemia.com
;; connection timed out; no servers could be reached
Any ideas - how do I go about troubleshooting this?

Do I need to have added this to the OVH manager?

DedicatedPros
17-07-2009, 15:49
Quote Originally Posted by NickW
What I do is on the godaddy panel find the host section. Add a host NS1 to the main IP of your server and add another host called NS2 and point that to a fail-over IP (you must have already set up the fail over IP on your server to eth0:0 or whatever). Then on the DNS server section on godaddy set the DNS servers to ns1.yourdomain.tld and ns2.yourdomain.tld where yourdomain.tld is the domain name that you have bought from godaddy (visumalchemia.com by the looks of things so you need to use ns1.visumalchemia.com and ns2.visumalchemia.com).

For this to work you need to be running your own DNS server software on your dedicated server ie. BIND or djbdns. If you're running a panel such as webmin/virtualmin you can easily configure BIND DNS server.
That would work, but its pointless as he said:

Quote Originally Posted by everwicked
Thank you both for the replies but as far as I understand, the configuration you're listing requires me to setup the BIND daemon on my server.

How can I do it so that the OVH nameservers handle it all?

NickW
17-07-2009, 15:19
What I do is on the godaddy panel find the host section. Add a host NS1 to the main IP of your server and add another host called NS2 and point that to a fail-over IP (you must have already set up the fail over IP on your server to eth0:0 or whatever). Then on the DNS server section on godaddy set the DNS servers to ns1.yourdomain.tld and ns2.yourdomain.tld where yourdomain.tld is the domain name that you have bought from godaddy (visumalchemia.com by the looks of things so you need to use ns1.visumalchemia.com and ns2.visumalchemia.com).

For this to work you need to be running your own DNS server software on your dedicated server ie. BIND or djbdns. If you're running a panel such as webmin/virtualmin you can easily configure BIND DNS server.

DedicatedPros
17-07-2009, 13:36
That configuration does not require binding nameservers to your server, its pretty much just plug and play.

You'd have to bind nameservers to the server if you wanted custom names (ie. ns1.mydomain.com) but if you use what OVH provides by default you're all set

everwicked
17-07-2009, 12:42
Guys,

Thank you both for the replies but as far as I understand, the configuration you're listing requires me to setup the BIND daemon on my server.

How can I do it so that the OVH nameservers handle it all?

DedicatedPros
17-07-2009, 10:18
The DNS servers you're using aren't the correct ones, they should be as follows:
Code:
For Kimsufi servers:
NS1 - ksXXXXX.kimsufi.com
NS2 - ns.kimsufi.com
Code:
For OVH Pro servers:
NS1 - nsXXXX.ovh.net
NS2 - sdns1.ovh.net
All you have to do is make sure the domain is properly configured on your server, if you're new to hosting I recommend you go with a control panel, cPanel is very good but costs about 30gbp a month, but Plesk is provided free on all servers, though for the kimsufi range you only get one domain.

EDIT: Damn you Neil 4 minutes late

Neil
17-07-2009, 10:14
Hi

If you want to point them directly to your dedicated server then log into your GoDaddy control panel and enter:

1) ns(thenumberofyourserver).ovh.net or ks(thenumberofyourserver).kimsufi.com
2) sdns1.ovh.net or ns.kimsufi.com

And after 24 to 48 hours everything should then load fine.

Neil

everwicked
17-07-2009, 03:12
Hello,

I have a few domains registered on GoDaddy.com which I want to point to my dedicated server on OVH without much success.

After searching, I added my domain through the manager main screen and added "Mail and web redirection (free service)" and then changes the DNS servers on GoDaddy to dns15.ovh.net and ns15.ovh.net

However my domain (visumalchemia.com) gives me an error on nslookup: connection timed out; no servers could be reached.

What am I doing wrong?

Thanks
Georgios