OVH Community, your new community space.

How to Put Domain on my Server?


pcoventry
21-09-2009, 17:17
Lucky bugger.

Mines not working so I had to get seperate -email from OVH in the end.

Ah well, can't win them all.

antdgar
23-07-2009, 17:56
Thanks guys, it works now

Just had to wait a while it seems

Neil
23-07-2009, 17:50
Whats the domain? It might be you just need the DNS to update now, only time will tell now... (24 48 Hours).

antdgar
23-07-2009, 17:47
Quote Originally Posted by DedicatedPros
you need to point your domain to these nameservers:

NS1 - kimsufiXXXX.kimsufi.com
NS2 - ns.kimsufi.com
Ok, I've just set ksxxxx.kimsufi.com as a nameserver. As I didn't do that before.

BUT, my IP address goes to my actual website...

DedicatedPros
23-07-2009, 17:40
The reverse is handled by the manager, you can change it there but it makes no difference.

I haven't used the ovh manager for managing domains so my help won't be as plentiful, but I'll try.

If you're using dedicated hosting (kimsufi for that matter) you need to point your domain to these nameservers:

NS1 - kimsufiXXXX.kimsufi.com
NS2 - ns.kimsufi.com

Then you do not need to manage the A/NS/MX records within the ovh manager but you can just do it within webmin as those guides suggested. Also it would help if you gave the domain you're trying to use, that way we could do check the records you set and make sure they're correct.

antdgar
23-07-2009, 17:17
Quote Originally Posted by DedicatedPros
Its redirecting to Horde, which is a webmail client, you must have setup a bad cname record. For the time being delete them all (they're useless unless you know what you're doing), you must likely only set one as one of those guides does tell you to, but its not necessary.

Once you remove the cname record your problem should go away.
Delete all the CNAMEs from OVH manager, right?

Also I edited 'Type A' to my dedicated server's IP. Is this right?
I've very confused about 'A' target address. Is it supposed to be default: 213.186.33.5
or 91.x.x.x.x (my server's IP)?!

When I ping mydomain.com it says the IP is: 213.186.33.5
But does NOT return any message. Just 'timeout' after a while.

And finally, OVH Manager looks like this:

NS = ns15.ovh.net
NS= dns15.ovh.net
MX1 = redirect.ovh.net
A = (my server's IP)

^And the field for each of these = .mydomain.com

And lastly,

field = www.mydomain.com
CNAME = mydomain.com

I hope someone can see what's wrong!

Reverse DNS is saying my IP resolves to ksxxxx.kimsufi.com (btw, i did not put ksxxxxx.kimsufi.com in any configuration whatsoever) [still mydomain.com is redirecting to imp OVH Horde website]

DedicatedPros
23-07-2009, 17:06
Its redirecting to Horde, which is a webmail client, you must have setup a bad cname record. For the time being delete them all (they're useless unless you know what you're doing), you must likely only set one as one of those guides does tell you to, but its not necessary.

Once you remove the cname record your problem should go away.

antdgar
23-07-2009, 16:35
Thanks,
I've set it up following those links.

However! My domain is redirecting to OVH's Mail Login-page:



Why is it doing this?!?!?

My apache directive is very simple:
Code:
DocumentRoot "/var/www"
ServerName mydomain.com
ServerAlias *.mydomain.com

allow from all
Options +Indexes

DedicatedPros
23-07-2009, 16:19
Go to create a master zone, and fill in the details (the name of the zone is your domain). Now you will need to set the proper NS, A, and MX records, though the MX record is optional as you only need that for using email on your server. I just dumped Webmin as its a very painful panel, but here are the guides I used when starting out (also Googling would have gotten results faster):

http://www.wallpaperama.com/forums/h...eps-t1706.html

http://rimuhosting.com/support/bindviawebmin.jsp

http://www.sitepoint.com/print/webmi...inistration-1/

antdgar
23-07-2009, 15:51
Quote Originally Posted by Neil
Well, you will need to BIND the domain to the server. Are you able to add the domain in Webmin? If so then just need to change the Name servers to:

1) ns(thenumberofyourserver).ovh.net or ks(thenumberofyourserver).kimsufi.com
2) sdns1.ovh.net or ns.kimsufi.com

If not then you will need to BIND the domain manually, http://help.ovh.co.uk/ManualBindServer which is complex for the first time.
Do you mean go here in webmin:
http://i187.photobucket.com/albums/x...icture2-27.png

BIND DNS Server?

OVHM is not available for my operating system (ubuntu 8.04)

Neil
23-07-2009, 15:19
Well, you will need to BIND the domain to the server. Are you able to add the domain in Webmin? If so then just need to change the Name servers to:

1) ns(thenumberofyourserver).ovh.net or ks(thenumberofyourserver).kimsufi.com
2) sdns1.ovh.net or ns.kimsufi.com

If not then you will need to BIND the domain manually, http://help.ovh.co.uk/ManualBindServer which is complex for the first time.

antdgar
23-07-2009, 15:08
jesus, that's far too complicated...

i'll just stick with using the ip address then

NickW
23-07-2009, 14:46
This thread may be of help.

http://forum.ovh.co.uk/showthread.php?t=2384

antdgar
23-07-2009, 14:35
Hi,

I'm completely new to web servers etc, but I suppose my question is simple.

How can I put my domain-name onto my server?

I have a dedicated Ubuntu server with Apache installed and webmin. I can access my website from the ip address, eg. 91.x.x.x.x and my website is fine.

How can I access it from mydomain.com though?

(and no I cannot use ovhm, it's not available on my operating system) Thanks!