We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Need to recompile the kernel


Myatu
23-01-2010, 00:53
I'm glad it worked for you!

Tsunulukai
22-01-2010, 22:59
I managed to boot my RPS from the hdd with a home-build kernel, thanks to your script !

It rocks !

I shared the tip with the community on the french forum... Hope you don't mind

Myatu
22-01-2010, 21:09
I'm aware my DNS is down at the moment. I'm re-arranging things and my backup DNS(OVH... AHEM!) took a p*** Sorry about that!

Tsunulukai
22-01-2010, 16:20
Seems that somehow my ISP cannot find DNS record for your website... OK finally got it, will try ASAP

Tsunulukai
22-01-2010, 14:14
Dear Myatu,

Could you repost your compiling script ?
The link on your previous post is obviously dead...

Regards,

Myatu
28-08-2009, 18:49
Hmm, that's something I've left out then since I don't use it Will have to fix that in my script-thingymajig...

kro
28-08-2009, 12:14
Alexei92 wrote:
> I've tried something like 10 of those config files. Then I downloaded
> another kernel.org version and tried it with those configs. No way. Then
> I tried a "clean" kernel from kernel.org. Nothing, too.


If you use a custom compiled kernel on a RPS, remember to keep the initrd from
the original kernel, and to configure lilo/grub accordingly.
--
Felix
OVH Team

derchris
27-08-2009, 20:46
I did a script for kernel compile once, but can't find the backup where it is.
But then it is not that advanced then yours.
Mine just grabs the latest source from kernel.org, will create a config file, and then create the bzimage and all the modules.
Nice work

Myatu
27-08-2009, 20:35
Well, I've seen a lot of people struggling with it so I figured I'll script the whole thing from beginning to end. Here's my first stab at it: http://bit.ly/aVMol

Just "tar xf bok.tgz", then "chmod +x bok.sh" and start with "./bok.sh -h" for some help or start compiling away simply with "./bok.sh".

It couldn't be easier - answer a couple Yes/No questions and you're off... I've tested it under Debian Lenny (5) and CentOS.

Only one thing: don't use the most recent kernel listed (Select "No" when asked if you want to use that version, then select the #2 from the list - that one seems to work best for both IPv6 and IPv4, etc).

It's a work in progress, so it's a bit "dirty" behind the scenes...

freshwire
27-08-2009, 19:33
Maybe the problem is elsewhere with your setup ?

Neil
27-08-2009, 16:15
Hi Alex

What is the problem you get, you need to use the kernel.org kernel and use our config file and everything should be fine?

Alexei92
26-08-2009, 21:26
I've tried something like 10 of those config files. Then I downloaded another kernel.org version and tried it with those configs. No way. Then I tried a "clean" kernel from kernel.org. Nothing, too.

Neil
24-08-2009, 12:00
Hi

The config files can be found here, ftp://ftp.ovh.net/made-in-ovh/bzImage/

Neil

Alexei92
22-08-2009, 22:08
.. i don't think I wrote bad my first message.
I've already done a lot of compilations. But none of these gave me a working kernel. I only need a working kernel. What parts of the kernel I have to keep built-in?

Neil
22-08-2009, 19:38
You can use your own kernel, you can follow the instructions for compiling a kernel just like you do for an OVH or Kimsufi server, but you will need to turn off monitoring because they take along time to boot up and sometimes the tech's switch them to netboot kernels.

Alexei92
22-08-2009, 19:37
The netboot kernels don't support modules.
And i think it is possible to run a custom kernel:
1) the default rps kernel on the hd can be booted, if I had that kernel's .config I could compile another kernel..
2) many people did it even on rps2 and rps3. I don't think it's impossible on rps1.

derchris
22-08-2009, 19:00
Are you actually able to get a custom kernel on a RPS.
I thought they all netboot.

Alexei92
22-08-2009, 18:51
Hi. I need to recompile the kernel of my RPS1 (i need to enable module support in order to install vmware server). I have tried maybe 20 different .config files. 20 compilations. But none of those made the server boot (i don't know the error..). I need a working .config for RPS1 (the old configuration: celeron 1.2 ghz, 512 mb ram, 10gb SAN space, etc). Thanks to everyone for help.