We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Millions of dropped packets in ifconfig


Myatu
23-09-2009, 22:18
Oops, I used FreeBSD's version. Indeed a bit different, but glad you figured it out and got it working

gregoryfenton
23-09-2009, 22:00
Thanks for the help

Using
Code:
ifconfig eth0 add 2001:41d0:2:2978::1/56
route --inet6 add default gateway 2001:41d0:2:29ff:ff:ff:ff:ff
I got it working
Code:
IPv6 traceroute

IPv6 traceroute from noc.sixxs.net  @ SixXS NOC, AS12871 to 2001:41d0:2:2978::1 :


Hop  Node                         Loss%  Sent   Last   Avg  Best Worst StDev       ASN        Organisation
  1. 2001:838:1:1::1               0.0%     5    0.4   0.4   0.4   0.4   0.0    [.nl] Netherlands, The 12871      Concepts ICT
     ge-1-3-0.breda.ipv6.concepts-ict.net.
  2. 2001:838:5:a::1               0.0%     5    1.9  35.0   1.9 167.4  74.0    [.nl] Netherlands, The 12871      Concepts ICT
  3. 2001:7f8:1::a500:6939:1       0.0%     5    2.5   2.3   2.2   2.5   0.1    [.nl] Netherlands, The            AMS-IX-IPV6
     ams-ix.he.net.
  4. 2001:7f8:1::a500:6453:1       0.0%     5   83.8  83.8  83.8  83.9   0.1    [.nl] Netherlands, The            AMS-IX-IPV6
     if-11-0-0.6bb1.ad1-amsterdam.ipv6.as6453.net.
  5. 2001:5a0:200::6               0.0%     5   84.0  84.2  83.5  85.0   0.6    [.ca] Canada 6453       Teleglobe International
     if-4-0.core1.AD1-Amsterdam.a6453.net.
  6. 2001:5a0:200:100::2           0.0%     5  111.2 131.5  85.4 279.8  83.5    [.ca] Canada 6453       Teleglobe International
     if-0-0.core2.AD1-Amsterdam.a6453.net.
  7. 2001:5a0:200:200::2           0.0%     5   84.0  97.8  83.7 153.4  31.1    [.ca] Canada 6453       Teleglobe International
     POS1-0.core1.B1D-Brusels.a6453.net.
  8. 2001:5a0:1400::a              0.0%     5   83.7  84.1  83.7  84.8   0.4    [.ca] Canada 6453       Teleglobe International
     if-7-0-0.core2.B1D-Brusels.a6453.net.
  9. 2001:5a0:0:100::9             0.0%     5  117.9  91.0  83.8 117.9  15.0    [.ca] Canada 6453       Teleglobe International
     POS5-0.core3.PG1-Paris.a6453.net.
 10. 2001:5a0:1900::1              0.0%     5   84.4 102.1  84.3 173.3  39.8    [.ca] Canada 6453       Teleglobe International
     if-9-1.har1.PV0-Paris.a6453.net.
 11. 2001:5a0:1900::a             20.0%     5   99.6 100.9  86.4 126.8  18.1    [.ca] Canada 6453       Teleglobe International
 12. ???                          100.0     5    0.0   0.0   0.0   0.0   0.0    
 13. ???                          100.0     5    0.0   0.0   0.0   0.0   0.0    
 14. 2001:41d0:2:2978::1          80.0%     5   88.0  88.0  88.0  88.0   0.0    [.fr] France 16276      SARL Ovh

Myatu
23-09-2009, 20:00
Quote Originally Posted by gregoryfenton
Code:
#eth0 is enabled during initrd
auto eth0
#iface eth0 inet6 static
#        address 2001:41D0:2:2978::1/56
#        netmask 56
#        gateway 2001:41d0:2:29ff:ff:ff:ff:ff
Just drop the "/56" portion on the address (you specify it with "netmask 56" as you've done on the next line).

You can also add it manually, using:

Code:
ifconfig [interface] inet6 [ipv6 address] prefixlen [bits]
So in your case, it would be:

Code:
ifconfig eth0 inet6 2001:41d0:2:2978::1 prefixlen 56
And to add the default route (gateway) you can use:

Code:
route -n add -inet6 default [gateway]
And in your case, that would be:

Code:
route -n add -inet6 default 2001:41d0:2:29ff:ff:ff:ff:ff
This allows you to test things without having to modify the network interface config, to ensure everything works. You could even add this in a shell script if you don't want (or can't) use it in the network config.

My favourite external checking tool is http://www.sixxs.net/tools/traceroute/ - just pick an IPv6 starting location, enter your IPv6 address and check if your server is reachable from the outside world.

Neil
23-09-2009, 15:09
The RPS takes along time to boot up from an HD Kernel, around 30 Minutes, so turn off monitoring in the OVH Manager then try to boot from the HD Kernel.

gregoryfenton
23-09-2009, 14:41
Ok, got somewhere but not how I wanted to get there.

Changed to boot to the netboot 2.6.28.4-xxxx-std-ipv6-64 (it won't boot when switched to hd) which has cured the dropped packets issue.

Now I am trying to configure IPV6 and am getting nowhere fast (apart from locking myself out of my server for a while)

How do I go about modifying /etc/network/interfaces to give the server the IPV6 information?

Current contents are
Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

#eth0 is enabled during initrd
auto eth0
#iface eth0 inet6 static
#        address 2001:41D0:2:2978::1/56
#        netmask 56
#        gateway 2001:41d0:2:29ff:ff:ff:ff:ff

auto eth0:0
iface eth0:0 inet static
	address 87.98.154.77
	netmask 255.255.255.255
The commented out lines under eth0 are the correct IPV6 settings, however enabling them causes the server to fail to bring up the network, forcing a netboot rescue pro boot.

Any ideas on just what I am missing?

gigabit
22-09-2009, 22:57
In the manager - is the RPS set to boot from the hard drive?

gregoryfenton
22-09-2009, 22:19
Thanks

I have a new query now, I have made a custom kernel (2.6.28.4, ipv6, 64 bit) by following the guide at http://forum.ovh.co.uk/showpost.php?p=2985&postcount=2 and modifying it for 64 bit etc.

How do I get it to boot to my new kernel?

I have added it to lilo.conf and set it as default as instructed.

My problem seems to be tied to this line in my kern.log:
Code:
kernel: Command line: root=/dev/ram0 initrd=iscsi/initrd-iscsi-x86_64.img libusual.bias=ub console=tty0 BOOT_IMAGE=rps/bzImage-2.6-xxxx-grs-ipv4-64
I am inclined to think that rps/bzimage-2.6-xxxx-grs-ipv4-64 is an external image (because of the rps/ part) and that therefore I cannot actually control which kernel is booted from my server using lilo.

Is this indeed the case? Am I truly at the mercy of the (admittedly very nice and well meaning) OVH admins when it comes to deciding which kernel I can run at bootup?

Myatu
22-09-2009, 14:38
No, these won't show up in either iptables or a tcpdump. It's a kernel driver issue in Ubuntu 8.10 that's been solved with 2.6.27-11.

gregoryfenton
22-09-2009, 12:38
Ubuntu server 8.10 64 bit on an RPS1 (r28394.ovh.net)

Output from
Code:
date && ifconfig && sleep 5 && date && ifconfig
Code:
Tue Sep 22 13:25:41 CEST 2009
eth0      Link encap:Ethernet  HWaddr 00:1c:c0:ca:75:bd  
          inet addr:94.23.40.120  Bcast:94.23.40.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1368326 errors:0 dropped:124653088 overruns:0 frame:0
          TX packets:1832285 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:472801287 (472.8 MB)  TX bytes:1855004345 (1.8 GB)
          Interrupt:252 Base address:0x4000 

eth0:0    Link encap:Ethernet  HWaddr 00:1c:c0:ca:75:bd  
          inet addr:87.98.154.77  Bcast:87.255.255.255  Mask:255.255.255.255
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:252 Base address:0x4000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2849 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2849 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:298339 (298.3 KB)  TX bytes:298339 (298.3 KB)

Tue Sep 22 13:25:46 CEST 2009
eth0      Link encap:Ethernet  HWaddr 00:1c:c0:ca:75:bd  
          inet addr:94.23.40.120  Bcast:94.23.40.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1368346 errors:0 dropped:128721376 overruns:0 frame:0
          TX packets:1832291 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:472802571 (472.8 MB)  TX bytes:1855006613 (1.8 GB)
          Interrupt:252 Base address:0x4000 

eth0:0    Link encap:Ethernet  HWaddr 00:1c:c0:ca:75:bd  
          inet addr:87.98.154.77  Bcast:87.255.255.255  Mask:255.255.255.255
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:252 Base address:0x4000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2849 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2849 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:298339 (298.3 KB)  TX bytes:298339 (298.3 KB)
In 5 seconds (128721376-124653088) = 4 068 288 dropped packets

I have just set up this server and I don't understand why there are so many of these dropped packets.

iptables output shows no blocked IPs
Code:
iptables -L
Code:
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination
In the five seconds gap I wasn't doing anything much, one SSH connection and the odd web page request.

I haven't got far into setting up the RPS (apt-get update, apt-get upgrade, install a LAMP server), I don't mind going back to the original and redoing it.

While writing this I did the first command again, it shows pretty much the same thing -- approximately 4 million dropped reads between the first and second ifconfig commands.

Any ideas?