We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Failover IP (adding it)


NickW
07-10-2009, 12:29
Code:
# ifconfig
dummy0    Link encap:Ethernet  HWaddr C6:62:08:8B:x:x
          inet addr:188.165.x.x  Bcast:188.165.x.a  Mask:255.255.255.255
          UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

eth0      Link encap:Ethernet  HWaddr 00:1C:C0:CA:x:x
          inet addr:94.23.x.x  Bcast:94.23.x.c Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:373244416 errors:0 dropped:928990491 overruns:0 frame:0
          TX packets:318680632 errors:0 dropped:414 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3999917272 (3.7 GiB)  TX bytes:381916822 (364.2 MiB)
          Interrupt:220 Base address:0x2000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:167802 errors:0 dropped:0 overruns:0 frame:0
          TX packets:167802 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:75160512 (71.6 MiB)  TX bytes:75160512 (71.6 MiB)

Edit: It doesn't matter really now as I've managed to get what I want using the other IP by an Iptables rule.

Razakel
07-10-2009, 01:12
Run ifconfig. What interfaces are there?

NickW
07-10-2009, 00:56
Basically, my RPS came setup with a failover already setup on it. The failover is 188.165.x.x and the normal one 94.23.x.x. When I first got the RPS they quoted the 188.165.x.x IP as the IP to use to connect to SSH etc which of course I did, only to find out that the 94.23.x.x is the main IP/the one outgoing traffic goes through, so of course I now use this one.

My problem now is that I want to use the 188.165.x.x address for something separate that needs a different IP. I thought all would be fine and I could create a new virtual interface for the failover (eth0:0) like I did with my Kimsufi.

I now realise that eth0 doesn't exist (I don't think?) on the server (CentOS 5.3) as when I tried creating an alias called eth0:0 I got an error and low and behold when I run the ls command I see the following:

Code:
# ls -a /etc/sysconfig/network-scripts
.             ifdown-ipsec   ifdown-tunnel  ifup-ipx     ifup-sl
..            ifdown-ipv6    ifup           ifup-isdn    ifup-tunnel
ifcfg-dummy0  ifdown-isdn    ifup-aliases   ifup-plip    ifup-wireless
ifcfg-lo      ifdown-post    ifup-bnep      ifup-plusb   init.ipv6-global
ifdown        ifdown-ppp     ifup-eth       ifup-post    net.hotplug
ifdown-bnep   ifdown-routes  ifup-ippp      ifup-ppp     network-functions
ifdown-eth    ifdown-sit     ifup-ipsec     ifup-routes  network-functions-ipv6
ifdown-ippp   ifdown-sl      ifup-ipv6      ifup-sit
Where the hell is eth0, or the config file for it to be precise (eth0 is listed in ifconfig so it is there and is valid and working) and how do I set up this failover IP so that I can use it in a way that I want?

(I have had a look at the config of dummy0):

Code:
# nano /etc/sysconfig/network-scripts/ifcfg-dummy0

DEVICE=dummy0
BOOTPROTO=static
IPADDR=188.165.x.x
NETMASK=255.255.255.255
ONBOOT=yes
Should I just go ahead and try using the interface dummy0 (it seems to have the failover IP) as an interface? How does dummy0 work, I have never used interfaces setup as dummy before.