We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Centos Vmware VPS Networking?


rick
26-05-2010, 15:30
Just noticed when I start the VM, the vmserver console reports

'Could not get interface address for vmnet1: Cannot assign requested address
Virtual device Ethernet0 will start disconnected.'

I also contacted support and they won't help, I think that's a but poor as they force you to use "host-only" networking mode. We have vmware servers in other DC's that work just fine.

marks
26-05-2010, 12:55
eth0 Link encap:Ethernet HWaddr 00:50:56:01:83:d4
inet addr:91.121.226.187 Bcast:91.121.226.255 Mask:255.255.255.255
inet6 addr: fe80::250:56ff:fe01:83d4/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1425749 errors:0 dropped:0 overruns:0 frame:0
TX packets:94503 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:131045503 (124.9 MiB) TX bytes:10679626 (10.1 MiB)
and the routing table:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
94.23.16.254 * 255.255.255.255 UH 0 0 0 eth0
default 94.23.16.254 0.0.0.0 UG 0 0 0 eth0
this and the VirtualMAC configuration should be enough.

rick
26-05-2010, 10:25
I rebooted and the server accepted the command

# route add default dev eth0

However I still can not ping the GW.

Do you have an example config for eth0 on the vps please?

Thanks for your help

HugeServer
24-05-2010, 17:41
Can you please copy the output here, or make a screenshot.

rick
24-05-2010, 14:00
Mant thanks for the reply.

However when i enter that command i get:

defauult: Host name lookup failure

And defauUlt is not a typo.

I can not ping the gw either.

Any ideas?

HugeServer
24-05-2010, 00:10
After you configured your network on your VPS, you have to route it to the main network:

# route add default dev eth0

and after that you should have the network on the vps. This setting will be lose after rebooting so do add this in following file : /etc/init.d/network

add it in the end of the file before the last line:

CWD=`route add default dev eth0`

rick
23-05-2010, 22:44
Hi has anyone set up a centos vmware vps with netoworking?
I tired to follow the ovh guide but its for debian?
Once on the host I can not ping the gateway even?

the guide (http://help.ovh.com/VMware) say's

file /etc/network/interfaces:
auto eth0
iface eth0 inet static
address # the VM's address
netmask 255.255.255.255
post-up /sbin/ip route add "Dedicated.Server.IP.but.end.in.254" dev eth0 #The gateway of the server
post-up /sbin/ip route add default via "Dedicated.Server.IP.but.end.in.254"

but on centos the file is the name of the network card and is like this example:

DEVICE=eth0
BOOTPROTO=static
ONBOOT=yes
HWADDR=00:30:48:33:bc:33
IPADDR=202.54.1.5
GATEWAY=202.54.1.3
NETMASK=255.255.255.248
IPV6INIT=yes
IPV6ADDR=2607:f0d0:1002:0011:0000:0000:0000:0002
IPV6_DEFAULTGW=2607:f0d0:1002:0011:0000:0000:0000: 0001

e.g you set it up like this
http://www.cyberciti.biz/faq/rhel-re...configuration/

Can anyone help please?

Thanks