OVH Community, your new community space.

grsecurity and plesk


Neil
07-06-2010, 15:58
Hi

Our default distribution with Plesk does not have grsc because of this known problem. If your server does have grsc kernel then you could change it to netboot kernel or compile your own kernel.

onesimpleman
07-06-2010, 10:21
Thank you for the help.
Tried 2 different versions of Netboot and the server looses the ping when I try netboot.

Message
"Our system of monitoring has just detected a defect on
your server . ......"

I will have to recompile the kernel now .

Myatu
06-06-2010, 20:03
Not all come with it, no.

If you are uncomfortable compiling your own kernel, the simplest method would be to access the OVH Manager, select your dedicated server and then Services. Under the "Netboot" option, you can select a kernel without grsec, for example 2.6.32 + SMP + IPv6.

The drawback of these kernels is that they are NOT modular. For most, this isn't an issue. However, if it does become an issue, simply search this forum for "compile kernel" or look in the How-To section for a few examples (there are several, specific to OVH).

onesimpleman
06-06-2010, 19:50
Does all OVH operating systems (centos) comes with grsecurity?
How can I remove grsecurity from Kernel?
I have a problem with grsecurity and plesk 9 where large number of processes are opened and eventually kills the server. (sw-engine-cgi) or I have to run cron every 2-3 hours to kill the processes.

Plesk forums attribute the problem to grsecuirty. As far as I know there are few other ovh customers with the same issue.
Thank You