OVH Community, your new community space.

Firewall problems

07-06-2010, 11:15
I can tell you that, for the firewall to work in our network, you have to follow this guide:

this would allow the firewall to work side by side with our monitoring system, and get the best of both things.

Regarding the issue on running the IP tables.
What RPS OS are you using? as far as I've tried them, all come with iptables support on the kernel. Have you checked if the iptables package is installed? If it is, you could try another kernel in the netboot.

07-06-2010, 01:11
Hi, i have been playing with my new RPS for the last couple of weeks now and am very happy overall, however i cannot get any firewall to work.

My IPtables seems broken, if i do :

iptables -L

i get this error :

iptables v1.3.8: can't initialize iptables table `filter': Table does not exist (do you need to insmod?)

and i also get errors when tring to apply rules.

I have tried setting rules in UFW and all seems to go well, i get a message : "Rules updated" after adding each rule but when i enable the firewall i am instantly locked out. I know i am adding rules for all the needed ports but it just wont work.

so i have tried the GUI addons, Firestarter and lokkit, with Firestarter and lokkit i can add rules for all the needed ports and that goes well but when i turn on the firewall again i am locked out.

I am 100% sure i am opening all the right ports and am not locking my self out so why am i being locked out.

I am very new to linux and am just learning but this just seems broken, and what does the iptables error mean :

"iptables v1.3.8: can't initialize iptables table `filter': Table does not exist (do you need to insmod?)"

How can i fix that error and get a firewall running, Please help.