OVH Community, your new community space.

VirtualBox on Ubuntu Server 10.04


cCMm
29-07-2010, 00:44
Alright just a little update for anyone having problems with this, i found a clear cut solution. (to me at least)

First you need to change the kernel, forget all that compile stuff. Here is what i did..

Might not be the best approach but it works

Make sure and backup all config files edited during this tutorial just in case you screw up.

First run this command to install new kernel, it will ask you if you want to keep your local grub config file i just said yeah..

Code:
sudo apt-get install linux-image-server
then edit your grub.cfg to boot from new kernel. What i did was just comment all the lines that where the OVH kernel and made sure the new kernel was set to boot first

Code:
sudo nano /boot/grub/grub.cfg
then reboot

Code:
sudo reboot
type uname -r and you should see you new kernel

Code:
uname -r
if you screw anything up just reboot into rescue mount your file system and replace original files you have edited.

Now install linux headers for your new kernel.

Code:
sudo apt-get install linux-headers-`uname -r`

That is it now just install Virtualbox and everything should go smoothly.

Code:
sudo apt-get install virtualbox-3.2
If you have previously installed Virtualbox make sure and remove it.
remove parenthesis and replace WHATEVERVERSION with you version.


Code:
sudo apt-get autoremove virtualbox-(WHATEVERVERSION) --purge

You should be golden now and have virtualbox running on you Ubuntu 10.04


remeber to install dkms package if you want the virtualbox kernel update if your kernel gets updated

Code:
sudo apt-get install dkms
and really i think virtualbox automatically installed it.


Once more note if you are having trouble getting Windows VM to recognize all cores remember to set you cores before windows installation for no issues.

Thats it hope this helps as i found no clear cut way to do this. Except for this.

cCMm
26-07-2010, 00:32
thank you kro for your reply that seemed to have worked as well

kro
15-07-2010, 17:24
cCMm wrote:
> other posts suggest getting rid of ovh kernel and recompiling new one.


Incidentally, Ubuntu Server 10.04 still has the ubuntu kernel installed, but
it's not used by default. You should be able to boot it by issuing two
commands:

chmod -x /etc/grub.d/06*
update-grub

Then a reboot. Keep in mind that:

- You will have to recompile the virtualbox module everytime you update the
ubuntu kernel
- For security reasons, you should update the ubuntu kernel everytime ubuntu
releases a kernel update
- OVH of course takes no responsibility for what happens when you use the
ubuntu kernel...
--
Felix
OVH Team

cCMm
15-07-2010, 06:45
thank you yonatan for your response, however ever guide and how to about creating new kernel refers to lilo and i dont have that i have grub. When i tried installing lilo it claims that it would not support the fact that i have software raid. does anyone know of any threads here on the forum that reference compiling new kernel with grub loader, i searched myself but was unable to find any.

Edit:

Some how or another there was>> Ubuntu, with Linux 2.6.32-23-generic in my grub.cfg so i just commented out OVH kernel, rebooted, and blam!!!

Virtualbox installed fine, however, now that i have windows xp installed as guest and even though i have selected the guest to use 4 processors it only shows it as using one in the taskmanager. Id like guest to be able to use all 4.

Anyone have any ideas on why its not using them all???

Also what are any disadvantages to using Ubuntu, with Linux 2.6.32-23-generic kernel??

Thanks

yonatan
15-07-2010, 05:41
It seems you would need to recompile your kernel.
That can be done from Rescue-Pro mode.
compile your kernel and place the image on your root file system.
configure your bootloader ( lilo / grub ) , and make it boot from HD

you set it rescue-pro and HD mode from your manager access, or using MoM.
http://www.ovh.co.uk/customerspace/software.xml

Good Luck :-)
I guess you can search the forum to find a nice how-to.

cCMm
15-07-2010, 01:53
Alright searched and searched about this all over forum with no luck. I had working once before but it seems that the thread has magically disappeared.

I am trying to install VirtualBox on Ubuntu Server 10.04 and i get this

Code:
Compilation of the kernel module FAILED!
other posts suggest getting rid of ovh kernel and recompiling new one.

none of the tutorials or instructions for doing this seem to work with Ubuntu Server 10.04.

Anyhelp or direction towards such a tutorial would be appreciated.

Thanks