OVH Community, your new community space.

user induced bug in manager RTM


gregoryfenton
25-09-2010, 23:42
I followed http://forum.ovh.co.uk/showthread.php?t=3787

Be aware that part of it needs adjusting, look for my post in the thread further down.

If you get stuck give me a holler and I will happily sort it out for you.

Zoom
25-09-2010, 22:39
gregoryfenton,
What guide did you use for the non-ovh kernel install?

gregoryfenton
24-09-2010, 12:38
I did a manual install (non-ovh kernel) so I could get /proc/modules and the latest kernel.

This thread is mainly in case someone else does the same and has the same issue.

kro
23-09-2010, 12:34
gregoryfenton wrote:
> sudo apt-get install pciutils


Usually pciutils are installed on every OVH distrib. can you tell me which
distribution you had this issue on so that I can double-check?
--
Felix
OVH Team

Winit
23-09-2010, 12:09
Which distro and version? How was it installed?

gregoryfenton
23-09-2010, 11:04
I just installed RTM and on the ovh manager in the PCI devices section I got this message:
The information is incomplete. The RTM version installed on your server is probably obsolete
The issue is caused in ubuntu by the pciutils package not being installed, which has the 'lspci' program included.

sudo apt-get install pciutils

I would classify it as a bug as the script should handle a missing executable and be able to report it to the manager (maybe it could write "lspci missing" to the output file if lspci does not exist and the manager scans for the line) rather than output a generic - and clearly incorrect - error message.


Posted here for google search.