OVH Community, your new community space.

I am puzzled


Oleg
27-09-2010, 11:14
Okay, I made a really stupid mistake; that's why I couldn't boot the gentoo-sources kernel. But I fixed the mistake, and now that kernel is bootable.

slacker
26-09-2010, 08:31
If you want to be sure about what the problem is, boot in vKVM: it will show you where and when it fails.

99% you're missing some option/module in the kernel. If you don't have an initrd, you need to make sure you have the following compiled as static, not modules:
- chipset driver
- SATA driver
- Filesystem

yonatan
26-09-2010, 07:47
you are missing driver modules,

Oleg
26-09-2010, 06:52
My server has gentoo 10.1 installed, so I emerged gentoo-sources because I wanted to boot my own kernel; however, the server becomes unbootable if I try to do that, so I was forced to enable netboot to make the server bootable again, and now I just don't know what prevents the server from booting from its hard drive (meaning, booting that gentoo-sources kernel that I compiled). It looks like ovh uses grub to boot gentoo servers from their hard drives, so I tried modifying grub.conf and then ran grub-install, but the server still booted the ovh kernel (meaning it booted not gentoo-sources, but the ovh kernel from its hard drive) after I did that. Then I tried running the grub application itself and after re-installing grub to MBR, the server still booted the ovh kernel. Then I edited menu.lst in the grub directory and the server became unbootable after that, so I was forced to boot the server through netboot. But does anybody here know what the problem is? I used default settings when compiling the gentoo-sources kernel, so don't know what the problem is. Any ideas?