OVH Community, your new community space.

2TB issue on 10R Servers


glidewave
18-10-2010, 08:43
layman:

Well, partition type is pretty much standard (Linux ext3), I've also tried ext4 with same result.

Edit: If you mean Partition Table, it is set as msdos. However, editing the partition type effectively wipes the raid volume (by what the warning says), which requires a reinstall, which sets partition table to msdos again.

Edit 2: Tried gparted and same result, set to use max 2.8TB, applied, it created a 700GB part with unidentified errors and left 2TB unallocated.

layman
18-10-2010, 08:18
Are you sure the partition type supports 48-64bit addressing?
32bit partitions have a maximum of 2TB partitions.

Might try using a partition type that supports 48bit addressing.

glidewave
18-10-2010, 05:52
I've been trying to find a solution to this issue for a while now with no luck. I have a mg10r-amd and mg10rbestof, both with hard raid 2x1500GB. I go through the process of redoing the raid from mirrored to stripped with the lsi utility, then reimaging with the following structure:

/dev/sda1 40G as /
/dev/sda2 8G as SWAP

Whenever I try to partition the remaining space (2.8TB) as one partition for /home, regardless of using parted, fdisk or cfdisk - it always either ignores what I set and creates an 800GB volume or a 1.9TB volume with the remaining as free space (fdisk) or sometimes Unusable.

Raid volume info:
1 volume is active, 2 physical disks are active
Volume 0 is Bus 0 Target 0, Type IS (Integrated Striping)
Volume Name:
Volume WWID: 096db593f690cb95
Volume State: optimal, enabled
Volume Settings: write caching enabled
Volume draws from Hot Spare Pools: 0
Volume Size 2860536 MB, Stripe Size 64 KB, 2 Members
Member 0 is PhysDisk 1 (Bus 0 Target 10)
Member 1 is PhysDisk 0 (Bus 0 Target 1)


fdisk:
Disk /dev/sda: 2999.4 GB, 2999489396736 bytes
255 heads, 63 sectors/track, 364667 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000e4e0f

Device Boot Start End Blocks Id System
/dev/sda1 * 1 5100 40959969 83 Linux
/dev/sda2 5100 6120 8190976 82 Linux swap / Solaris

fdisk after trying to add partition:
Device Boot Start End Blocks Id System
/dev/sda1 * 1 5100 40959969 83 Linux
/dev/sda2 5100 6120 8190976 82 Linux swap / Solaris
/dev/sda3 6120 267349 2098329866 83 Linux

Leaves 97318 (~800GB) unused...and the kernel seemingly doesn't have GPT support.

I don't/shouldn't have to use another partition and separate things.... is there a solution to this?

Thanks!