OVH Community, your new community space.

Problems to revert standard Ubuntu 8.04 kernel


mika
25-10-2010, 11:45
Thanks. I will try to compile own kernel image and see if it helps.

Neil
25-10-2010, 11:27
If you compiled your own kernel and booted from HD then you should be able to do what you want. Our kernels do have configuration changes and are static kernels for security.

There is a guide that IainK did about compiling your own kernel, see http://forum.ovh.co.uk/showthread.php?t=239

mika
25-10-2010, 11:19
Do you mean that if using HD kernel compiled by myself I would get all standard Ubuntu OS functionality working, such as 'iptables-restore' which is not working with the default OVH kernel?

What would be difference by having own built kernel vs. having standard Ubuntu installation which I have now installed but cannot configure successfully?

At the moment I have had RPS server one month and I have not been able to use it as the program which I want to run fails when it tries to execute 'iptables-restore'. The same program works well in my other server so it's clearly issue with the OVH custom kernel.

How can I get it working? HD+compiled kernel or reverting to standard kernel as I'm trying to do at the moment?

Thanks for your support!

Neil
25-10-2010, 11:12
Quote Originally Posted by zydron
Neil, could you also explain why it takes so long?

sounds a bit unreal to me...
Since if you boot from the HD, this kernel has to come from the SAN (The Remote Storage), This a bottleneck, which is why by default all RPS uses the netboot.

zydron
25-10-2010, 10:53
Neil, could you also explain why it takes so long?

sounds a bit unreal to me...

Neil
25-10-2010, 10:50
Hi

It is possible to use the HD Kernel and compile your own, however it can take a long time to boot up, somewhere around the 30 minute mark. You will need to disable monitoring so we do not do an intervention on it.

zydron
24-10-2010, 17:30
never tried to be honest

I think you are the first

mika
24-10-2010, 17:28
Yes, apt-get update doesn't work and most likely like you said it's because of the kernel. That's why I chose to revert to standard kernel. In any case I want standard OS not any OVH specific stuff to make things difficult as I can never know when it stops working again if I need to update something.

Any ideas to original question, what could be wrong after installing standard OS?

zydron
24-10-2010, 17:15
I think apt-get don't work because it wants to update the kernel, propably
which don't work because you need some changes for the RPS platform.

but try it, we'll see

if you can get it work, you can also use ubuntu 10.10

mika
24-10-2010, 16:12
Thanks for the comments. I'm trying to revert standard kernel because OVH installations stops working if I install standard OS updates, 'apt-get upgrade', and also 'iptables-restore' command doesn't work.

I have checked the IP's and tried to setup proper configuration to /etc/network/interfaces.

xxx.xxx.xxx.xxx main IP
yyy.yyy.yyy.yyy fail-over IP

iface eth0 inet static
address xxx.xxx.xxx.xxx
netmask 255.255.255.0
network xxx.xxx.xxx.0
broadcast xxx.xxx.xxx.255
gateway xxx.xxx.xxx.254

auto eth0:0
iface eth0:0 inet static
address yyy.yyy.yyy.yyy
netmask 255.255.255.255

zydron
24-10-2010, 15:55
btw the IP you get in your mail, is NOT your main IP

so check your reverse IP page in manger

but to use your storage you need the fail-over IP (which is used in your mail)


so take our advice, and use OVH kernel

mika
24-10-2010, 15:38
hmm... I'm quite confident that I have harddrive even I'm suppose to have RPS as I'm able to access my Ubuntu installation and my partitions if rebooting to rescue-pro mode.

root@rescue:~# fdisk -l

Disk /dev/uba: 515 MB, 515899392 bytes
255 heads, 63 sectors/track, 62 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000dc4e3

Device Boot Start End Blocks Id System
/dev/uba1 * 1 13 104391 83 Linux
/dev/uba2 14 62 393592+ 8e Linux LVM

Disk /dev/sda: 21.4 GB, 21474836480 bytes
64 heads, 32 sectors/track, 20480 cylinders
Units = cylinders of 2048 * 512 = 1048576 bytes
Disk identifier: 0x000d296f

Device Boot Start End Blocks Id System
/dev/sda1 * 1 4768 4882416 83 Linux
/dev/sda2 4769 19073 14648320 83 Linux
/dev/sda3 19074 20480 1440768 83 Linux

zydron
24-10-2010, 15:22
because RPS servers don't have a harddrive

everything is remote from SANs

edit: if you install Ubuntu without harddrive, it will be installed into RAM, which erase by the next reboot

mika
24-10-2010, 15:18
Is there some specific reason why I shouldn't be doing this on an RPS? Shouldn't be just matter of configuration to get default OS working whether or not it's RPS or dedicated server?

Myatu
24-10-2010, 15:04
Quote Originally Posted by mika
After reboot server didn't reply to ping for a while, as expected, then replied to ping 13 times and after that no ping responses.
Edit: Scratch my previous comment.

Are you trying to do all this on a RPS? You really shouldn't do it on an RPS...

mika
24-10-2010, 14:15
Hi

I'm having problems with reverting Ubuntu Server 8.04 LTS OVH kernel to standard Ubuntu kernel. After reboot server didn't reply to ping for a while, as expected, then replied to ping 13 times and after that no ping responses.

I'm following remote Ubuntu installation (debootstrap) instructions defined here: http://forum.ovh.co.uk/showthread.php?t=3787 with the difference that Ubuntu is installed from http://archive.ubuntu.com/ubuntu/ not from OVH server.

I have been trying to revert kernel already 2 weeks without success and spend tens of hours to search information but I cannot find solution how to revert the kernel successfully. I'm not very familiar with Linux so I might be missing some basic thing.

Any ideas or help how to fix this problem would be highly appreciated.

BR,
Mika