We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Problem with apt-get


Bruno
02-03-2008, 19:05
Wait two minutes, I reinstall my server with Ubuntu to test this.

EDIT : ok, we posted at the same moment

Lam3r_co
02-03-2008, 19:05
woot, it solved the problem!
Thank you again Bruno!

Lam3r_co
02-03-2008, 19:04
Code:
deb ftp://mirror.ovh.net/ubuntu/ feisty main restricted
deb-src ftp://mirror.ovh.net/ubuntu/ feisty main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb ftp://mirror.ovh.net/ubuntu/ feisty-updates main restricted
deb-src ftp://mirror.ovh.net/ubuntu/ feisty-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb ftp://mirror.ovh.net/ubuntu/ feisty universe
deb-src ftp://mirror.ovh.net/ubuntu/ feisty universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb ftp://mirror.ovh.net/ubuntu/ feisty multiverse
deb-src ftp://mirror.ovh.net/ubuntu/ feisty multiverse


deb http://mirror.ovh.net/ubuntu feisty-security main restricted
deb-src http://mirror.ovh.net/ubuntu feisty-security main restricted
deb http://mirror.ovh.net/ubuntu feisty-security universe
deb-src http://mirror.ovh.net/ubuntu feisty-security universe
deb http://mirror.ovh.net/ubuntu feisty-security multiverse
deb http://ftp.crihan.fr/ubuntu/ feisty main universe restricted multiverse
deb-src http://ftp.crihan.fr/ubuntu/ feisty main universe restricted multiverse #Added by software-properties
deb http://ftp.crihan.fr/ubuntu/ feisty-security universe main multiverse restricted
deb-src http://ftp.crihan.fr/ubuntu/ feisty-security universe main multiverse restricted #Added by software-properties
deb http://ftp.crihan.fr/ubuntu/ feisty-updates universe main multiverse restricted
deb-src http://ftp.crihan.fr/ubuntu/ feisty-updates universe main multiverse restricted #Added by software-properties
deb-src http://mirror.ovh.net/ubuntu feisty-security multiverse
deb http://mir1.ovh.net/ubuntu feisty main
Now this is weird:

Code:
admin@ks355037:~$ sudo dpkg -r --force-remove-reinstreq postfix
dpkg - warning, overriding problem because --force enabled:
 Package is in a very bad inconsistent state - you should
 reinstall it before attempting a removal.
(Reading database ... 
dpkg: serious warning: files list file for package `postfix' missing, assuming package has no files currently installed.
87366 files and directories currently installed.)
Removing postfix ...

Bruno
02-03-2008, 18:55
What are your sources ?

$ cat /etc/apt/sources.list

Try this :
$ apt-get update
$ sudo dpkg -r --force-remove-reinstreq postfix

Lam3r_co
02-03-2008, 18:49
Hi.
Ive got another problem.. :/
I use Ubuntu 7 Desktop.
I tried to install postfix, but it crashed and left something incompleted. Now I cannot use apt-get. I always get the same error:

Code:
admin@ks355037:~$ sudo apt-get install bind9
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: The package postfix needs to be reinstalled, but I can't find an archive for it.
admin@ks355037:~$ sudo apt-get check
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: The package postfix needs to be reinstalled, but I can't find an archive for it.
admin@ks355037:~$ sudo apt-get remove postfix
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: The package postfix needs to be reinstalled, but I can't find an archive for it.
When I download package and open it, it always says "Could not open 'packagename'. The package might be corrupted or you are not allowed to open the file"
I downloaded bunch of packages from thousands of mirrors, tried older versions, etc. I set read-write permission for every user. I restarted system twice. But it is still not working.

Please help, Im such a noob with linux
Thanks