OVH Community, your new community space.

understanding IP's with ovh { help }


Neil
20-06-2011, 17:38
I think with IP Alias you cannot do what you want to do, since it uses the Main Network Interface to route outgoing traffic. I think you will need to use Virtual Machines so that the traffic then uses the IP Address of the Virtual Machine.

avizeke
18-06-2011, 02:50
Ok i have removed plesk did a fresh install. it is centos 5.5

and i started the IP alias that ovh recomends i follow

this is default Device

DEVICE=eth0
BOOTPROTO=static
IPADDR=188.165.255.***
NETMASK=255.255.255.0
ONBOOT=yes
GATEWAY=188.165.255.254


this is me adding the fail over ip

DEVICE=eth0:0
BOOTPROTO=static
IPADDR=87.98.241.***
NETMASK=255.255.255.255
ONBOOT=yes
BROADCAST=87.98.241.***


the aspects that i changed was the name of the device the ips, and the netmask.

the ip is pingable and works ok. however it still redirects to its primary ip, i cant place services on the fail safe ip, without the services been forced to be redirected to the static origional ip.

Neil
10-06-2011, 09:33
Quote Originally Posted by avizeke
ok ama write my actions in full here.

i have plesk 9.5 with centos 5.5

i folowed this http://help.ovh.com/IpAlias for centos



this is my outcome

DEVICE=eth0:0
BOOTPROTO=static
IPADDR=178.32.58.45
ONBOOT=yes
BROADCAST=178.32.58.45

NETMASK=255.255.255.0
GATEWAY=188.165.255.254


The game servers arnt picking up this ip what so ever. even though it pings do i need to address iptables ?

am i putting it in correctly ?

do i need to do something on plesk ?
I think you have an issue here of running Plesk and Gameservers, but you should remove the above and add it to the Plesk Control Panel, under IP Addresses and you add the ip failover by IP.FAILOVER/32 in the box.

Then it may work for your gameserver as well.

If you have to add it to your gameserver, the netmask should be 255.255.255.255 and if it is an Alias then you will not need the Gateway.

avizeke
09-06-2011, 20:46
ok ama write my actions in full here.

i have plesk 9.5 with centos 5.5

i folowed this http://help.ovh.com/IpAlias for centos



this is my outcome

DEVICE=eth0:0
BOOTPROTO=static
IPADDR=178.32.58.45
ONBOOT=yes
BROADCAST=178.32.58.45

NETMASK=255.255.255.0
GATEWAY=188.165.255.254


The game servers arnt picking up this ip what so ever. even though it pings do i need to address iptables ?

am i putting it in correctly ?

do i need to do something on plesk ?

avizeke
09-06-2011, 20:25
DEVICE=eth0:0
BOOTPROTO=static
IPADDR=178.32.58.45
ONBOOT=yes
BROADCAST=178.32.58.45



does that look ok for failsafe ip. i removed netmask as well

avizeke
09-06-2011, 20:16
steam based HL1 and HL2 based servers are pretty much standard and work.

its how ips are situated from ovh that i am trying to get my head around.

executing in screen the server with a specific ip and port then switches later on changing it to the direct ip that was issues with the dedi system that ovh gives the consumer.

standard command line been

./srcds_run -console -autoupdate -game dods +ip iphere -port porthere +map +maxplayers


when you type the command out with the failsafe ip it works until eventually the fialsafe ip then redirects and uses the primary ip.

marks
09-06-2011, 17:12
Quote Originally Posted by avizeke
When i assign it to a fail safe ip it works for a while but in essense it then eventually uses the primary ip rather than the fail safe one.
When you say "it then eventually uses...", you mean the game server software, right?

I think it must be how the software uses the IPs. Check the documentation/website of the game server on how different IPs are meant to be configured. Let us know if you need any help on that sense.

could it be to do with plesk assigning the domain to that ip and not the fail safe ips, giving priority to the primary ip or is it just how ovh addresses this were i need to configure it in my ssh file area.
Plesk can be configured so you assign a domain to an IP exclusively (the domain would only answer when requested to that IP).

Though I'm not sure what Plesk or a domain has anything to do with your game server.

avizeke
09-06-2011, 15:17
could it be to do with plesk assigning the domain to that ip and not the fail safe ips, giving priority to the primary ip or is it just how ovh addresses this were i need to configure it in my ssh file area.

avizeke
09-06-2011, 15:14
When i assign it to a fail safe ip it works for a while but in essense it then eventually uses the primary ip rather than the fail safe one.

so i think i need to configure the fail safe ips so that they dont redirect to teh stable primary ip on the server.


What happens is when i set the typical game server up on the fail safe ip it starts up on that ip but eventually changes its ip to the primary one.

i need to configure the fail safes so that it doesnt attempt to redirect to the primary one.

marks
09-06-2011, 09:53
I'm not sure what you mean by "it kicks back in to the primary ip"

can you explain a bit more about it? provide logs so we can see the behaviour.

avizeke
09-06-2011, 04:28
can anyone suggest what the proper method is in order for me to use the fail over ips so that they dont redirect.

is it iptables i edit as well as following the ip alias aspect ?

avizeke
07-06-2011, 04:32
hey guys thanks for your responses ! good to see a proper forum with actual assistance.

The configuration aspect of altering may be the problem at hand. the only effort i have to configuring is just to actually add the ip's via the ovh ip alias page ! that is the only configuring i have done. then ping'd them and it worked fine. When manually screening a game server to a fail over ip, it works but then eventually changes ip to static main ip.

( matt37)
I have proficent knoledge on gameservers and how they are set, i assumed i was good with linux . network management is now my weakness


i made sure it was the fail over, but it kicks back in to the primary ip. Fail over does actually work, for a while then goes back to primary ip. So maybe i am doing the ipalias cfg's wrong .

hmmm

i am running centos 5.

mattb37
04-06-2011, 19:51
What operating system are you running, would it be Windows?

What game servers are setting up?

As already said you are probably configuring the game servers wrong. Feel free to pm me with more details if you dont want to discuss this openly in the forums; I have been hosting game servers for many years now and will hapily help you out.

Matt.

Razakel
03-06-2011, 18:05
Quote Originally Posted by avizeke
if i run one on a fail safe it eventually at some point uses the static ip instead rather than the fail safe
That'll be a configuration problem with the game server. Check the config and make sure the IP you're telling it to bind to is actually your failover IP.

marks
03-06-2011, 16:21
you can definitely set a service to listen to only the IP failover. But as I said, most of the services use the main IP to reply to a request. I don't see why that should be a problem.

In any case, that's the default behaviour for a Linux server. Not sure about the other OSes, but in any case, it's a software issue. To get the system to behave differently, you'll need to configure it.

avizeke
03-06-2011, 13:48
Ok thanks for your response.

i did the matters of ip alias on ovh's website and just had problems were when i used a software on that ip only. i think it rejected it and then went to the main ip instead.

say for example game servers. if i run one on a fail safe it eventually at some point uses the static ip instead rather than the fail safe

marks
03-06-2011, 09:42
whats the different between ripe ips and fail safe guys ?
In terms of the problem you find above, there is no difference.

I don't think the problem you have is due to "how ovh situate ips for the main system that you use". OVH sets up the routing to any given IP (main or failover) the same way. It's then the servers that will always have a main IP (the outgoing communication is done using this main IP as source IP) and extra IPs (IP alias).

If you configure the IPs failover as IP alias (eth0:0 and so), they are pingable. It's not redirected and they are stable on the server.

I'm not entirely sure what you mean by "redirected back to the static IP", but if it's the fact that no matter what IP you request communication to, the server will reply back with the main IP, then it's a software thing. Nothing to do with the network or routing.

If that's the problem, I believe some people has tried to address this using iptables and changing the source IP for the outgoing packets.

Let us know more

avizeke
03-06-2011, 02:20
Hey guys

My current problem is how ovh situate ips for the main system that you use. I am trying to get ip's to work for the system and not redirect to the static ip.

i am running basically a few game servers and want to address the ips as not redirects but for them to actually be stable on the ip rather than redirect it to the main stable server that came with your dedi server.

I have done IPAlias that ovh help suggests, and then ping'd the ip which worked fine... then when you situate any services on there its still redirected back to the static ip.

whats the different between ripe ips and fail safe guys ?