OVH Community, your new community space.

IPv6 & Proxmox


Myatu
26-01-2013, 20:47
Glad it works!

OVH has sent us Christmas presents for the past few years, which I think is a very nice gesture Besides, I'm just happy I can do something for others - and learn from others as well...

Monaro
26-01-2013, 18:29
Code:
sysctl -w net.ipv6.conf.all.forwarding=1
sysctl -w net.ipv6.conf.all.proxy_ndp=1
Was the Answer, thank you indeed, Myatu now i can crack on with testing.

OVH really really should be taking note of the people like Andy and Myatu, they provide an invaluable service and from where im sitting they get little to no thanks, so guys/gals thank you!! and please keep up the good work.

IPV6 Solved.

Topic Closed

Myatu
25-01-2013, 01:44
Hmm, seems the ndp isn't doing its thing. You can try substituting "eth0" with "all" for the proxy_ndp configuration in the sysctl or networking/interfaces stanza, to cover that as a potential issue. If it works correctly, you should be able to see the ip with "ip -f inet6 neigh".

Monaro
23-01-2013, 13:05
I get the distinct impression ill end up kicking myself here but.


Code:
root@proxmox1:/etc/vz# tcpdump -i vmbr0 icmp6
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on vmbr0, link-type EN10MB (Ethernet), capture size 65535 bytes
12:59:30.680375 IP6 2001:41d0:8:5b5c::1001 > 2620:0:ccc::2: ICMP6, echo request, seq 7, length 64
12:59:30.700421 IP6 fe80::6e50:4dff:feae:a900 > ff02::1:ff00:1001: ICMP6, neighbor solicitation, who has 2001:41d0:8:5b5c::1001, length 32
12:59:31.680369 IP6 2001:41d0:8:5b5c::1001 > 2620:0:ccc::2: ICMP6, echo request, seq 8, length 64
Result in attempting to Ping to Container
Code:
IPv6 Ping Output:
PING 2001:41d0:8:5b5c::1001(2001:41d0:8:5b5c::1001) 32 data bytes
From 2001:41d0::a42 icmp_seq=0 Destination unreachable: Address unreachable
Result in attempting to Ping from Container
Code:
[root@proxmox1~]# ping6 2620:0:ccc::2
PING 2620:0:ccc::2(2620:0:ccc::2) 56 data bytes
^C
--- 2620:0:ccc::2 ping statistics ---
135 packets transmitted, 0 received, 100% packet loss, time 134048ms
I can ping from Proxmox Host to Container and Container to Proxmox host, just nothing when attempting inside/out outside/in

I have gone through the guide, and checked i have added all the lines required, they are all present and correct......

Myatu
23-01-2013, 12:17
Have you followed the other parts of the referenced post, too? That is with /etc/sysctl.conf and vz.conf? That should be all that's required to have IPv6.

You could also run "tcpdump -i vmbr0 icmp6" on the host whilst you try and use ping6 from the container, and see if it ever arrives at the host, and what the host does with (reply, drop, etc.)

Monaro
23-01-2013, 10:27
Okay I updated the post-up mistake, even i should have noticed that, and the IP's i listed are a typo, i checked to confirm the existance of the :: it was there, i just copyed it down wrong.

I have tryed what you suggested, but still i am unable to answer.

As this is a non-production box, i would be willing to allow remote help, after all once ive seen how its done ill understand better, i tend to learn better by see how it should be done. So if you feel you can help drop me a line.

Myatu
23-01-2013, 09:37
Quote Originally Posted by Monaro
...
Info Files. /etc/network/interfaces

Code:
...
iface vmbr0 inet6 static
...
        post-up /proc/sys/net/ipv6/confg/eth0/proxy_ndp
The "post-up" is incorrect. It needs to be:

Code:
post-up echo 1 > /proc/sys/net/ipv6/conf/eth0/proxy_ndp
Alternatively, you can add this to /etc/sysctl.conf with

Code:
net.ipv6.conf.eth0.proxy_ndp=1
Also make sure you're using the correct IP formatting. You've mentioned 2001:41d0:8:5b5c:1000, which is an invalid format (requiring a double "::" in front of 1000).

Monaro
22-01-2013, 21:14
Post Referance http://forum.ovh.co.uk/showthread.php?t=3497 Proxmox IPv6

I have spent a few hours playing about with proxmox today, having had to delay my migration i thaught id get to playing around, as far as i can figgure the only VPS/OpenVZ platform available from OVH that supports IPv6 is Proxmox

So, i followed the guide, and at first it all seemed to go very very well, i got proxmox to answer. But when i assign an IP to a Container, i get no reply.

Info Files. /etc/network/interfaces

Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# for Routing
auto vmbr1
iface vmbr1 inet manual
        post-up /etc/pve/kvm-networking.sh
        bridge_ports dummy0
        bridge_stp off
        bridge_fd 0


# vmbr0: Bridging. Make sure to use only MAC adresses that were assigned to you.
auto vmbr0
iface vmbr0 inet static
        address 37.59.xxx.xxx
        netmask 255.255.255.0
        network 37.59.xxx.xxx
        broadcast 37.59.xxx.xxx
        gateway 37.59.xxx.254
        bridge_ports eth0
        bridge_stp off
        bridge_fd 0

iface vmbr0 inet6 static
        address 2001:41D0:8:5B5c::1
        netmask 64
        post-up /sbin/ip -f inet6 route add 2001:41D0:8:5Bff:ff:ff:ff:ff dev vmbr0
        post-up /sbin/ip -f inet6 route add default via 2001:41D0:8:5Bff:ff:ff:ff:ff
        post-up /proc/sys/net/ipv6/confg/eth0/proxy_ndp
        pre-down /sbin/ip -f inet6 route del default via 2001:41D0:8:5Bff:ff:ff:ff:ff
        pre-down /sbin/ip -f inet6 route del 2001:41D0:8:5Bff:ff:ff:ff:ff dev vmbr0
Commands Used to Add IPv6 to Containers
Code:
vzctl set 100 --ipadd 2001:41d0:8:5b5c::1000/64 --save
ip -6 neigh add proxy 2001:41d0:8:5b5c::1000 dev vmbr0
No reply to pings, so i did
Code:
ip -6 del proxy 2001:41d0:8:5b5c:1000 dev vmbr0
and tryed instead

Code:
ip -6 add proxy 2001:41d0:8:5b5c:1000 dev eth0
Still no joy, and here i am, looking for some help, im still getting to grips with IPv6 but i got Proxmox to answer on 2001:41d0:8:5b5c:1 i just cant get the VPS Containers to Answer.

Any help is greatly apreciated