OVH Community, your new community space.

Upgrading PHP on my RPS


Neil
11-02-2013, 11:44
Hi

We would recommend you look at our VPS 2013 coming soon or a Dedicated Server. Debian Squeeze is not supported on the RPS.

Myatu
09-02-2013, 17:33
Security updates for Debian Lenny have been discontinued (since February 6th 2012). Either upgrade to Debian Squeeze, or remove/comment the repository from /etc/apt/sources.list file.

wwwicked
08-02-2013, 20:43
Hello, please can someone tell me how to upgrade PHP on my RPS?

Code:
$ uname -a
Linux r30315.ovh.net 2.6.32.2-xxxx-grs-ipv4-32 #1 SMP Tue Dec 29 14:41:18 UTC 2009 i686 GNU/Linux
Currently, I have 5.3.5:

Code:
r30315:/home/sites# php --version
PHP 5.3.5-0.dotdeb.0 with Suhosin-Patch (cli) (built: Jan  7 2011 01:47:26)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
    with Suhosin v0.9.32.1, Copyright (c) 2007-2010, by SektionEins GmbH
I want to update to 5.4.x, but the things I've tried all result in failure. I've tried various commands, such as these:

Code:
apt-get update
apt-get upgrade php5
apt-get upgrade php5 --fix-missing
apt-get dist-upgrade
If I try to upgrade PHP5, the command looks as though it's going to work (kept back packages notwithstanding):

Code:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
  bind9 bind9-host bind9utils dnsutils libapache2-mod-php5 libbind9-40 libdns45 libisc45 libisccc40 libisccfg40 liblwres40 mysql-client mysql-client-5.0 mysql-server
  mysql-server-5.0 php-pear php5 php5-cli php5-common php5-curl php5-dev php5-gd php5-mysql php5-suhosin webmin
The following packages will be upgraded:
  apache2 apache2-mpm-prefork apache2-threaded-dev apache2-utils apache2.2-common apt apt-utils base-files bind9-doc bzip2 cpio debian-archive-keyring dhcp3-client
  dhcp3-common dpkg exim4 exim4-base exim4-config exim4-daemon-heavy gzip iputils-ping libapr1 libapr1-dev libbz2-1.0 libc6 libc6-dev libc6-i686 libcurl3
  libdbd-mysql-perl libfreetype6 libkadm55 libkrb5-dev libkrb53 libmysqlclient15-dev libmysqlclient15off libperl5.10 libpng12-0 libpq-dev libpq5 libssl-dev libssl0.9.8
  libwww-perl libxml2 linux-libc-dev locales login man-db nano ntpdate openssl passwd perl perl-base perl-modules python2.5 python2.5-minimal spamassassin spamc sudo tar
  tzdata usbutils w3m wget
64 upgraded, 0 newly installed, 0 to remove and 25 not upgraded.
Need to get 64.7MB of archives.
After this operation, 377kB of additional disk space will be used.
Do you want to continue [Y/n]?
But then I get a load of file not found and 404 errors:

Code:
Get: 9 ftp://mir1.ovh.net lenny/main perl 5.10.0-19lenny3 [4570kB]
Err ftp://mir1.ovh.net lenny/main perl 5.10.0-19lenny3
  Unable to fetch file, server said 'Failed to open file.  ' [IP: 91.121.124.139 21]
Get: 10 ftp://mir1.ovh.net lenny/main libperl5.10 5.10.0-19lenny3 [623kB]
Err http://security.debian.org lenny/updates/main linux-libc-dev 2.6.26-26lenny2
  404 Not Found [IP: 212.211.132.32 80]
Err http://security.debian.org lenny/updates/main dhcp3-client 3.1.1-6+lenny5
  404 Not Found [IP: 212.211.132.32 80]
I've tried dist-upgrade, which says:

Code:
The following packages will be upgraded:
  ... php5-common php5-suhosin ...
But that's the same problem:

Code:
Err http://security.debian.org lenny/updates/main apache2 2.2.9-10+lenny9
  404 Not Found [IP: 195.20.242.89 80]
Err http://security.debian.org lenny/updates/main libcurl3 7.18.2-8lenny4
  404 Not Found [IP: 195.20.242.89 80]
Err http://security.debian.org lenny/updates/main libmysqlclient15-dev 5.0.51a-24+lenny5
  404 Not Found [IP: 195.20.242.89 80]
So, what's the best, reliable way to update PHP to 5.4.x? Can I just compile from source? Should I edit a config file somewhere?