OVH Community, your new community space.

Proxmox VM migration issue


makno
03-06-2013, 18:17
well i allready tied with scp and ftp. Only thing i can think of doing now is to start the VM and route a port to it from the host so i can access ftp running on the VM from the internet. I believe i need to use NAT but not sure how so will need to read around. Sadly i just got home now after 5 days away due to job interviews hence why i din't reply before

DigitalDaz
31-05-2013, 22:56
I won't be much help here except to say I have had exactly the same errot before with proxmox and it was a disk error.

A reinstall of the OS and then just move what a could between the old VM and new VM using scp.

makno
30-05-2013, 20:08
well i am not at home and can't get on my home pc from here anymore however last i remember the scp trransfer trial ended at 233Gb with a "stalled" error message.

i have run out of ideas :/

makno
29-05-2013, 14:13
well i'm trying with scp at the moment from rescue mode so i should see in about 6 hours if it fails or not but i think it will as even rar and split had problems stopping right at the ame point.
i'm wondering if it might be a disk error.

With regards to the network keeping in mind that the proxmox host has the ovh net setup (proxmox 1.9) i just gave the VM an ethernet interface from proxmox cp and set it as bridget on vmbr0.
The vm has a dhcp address of 10.0.2.15 and gateway 10.0.2.2
From the VM i can ping 10.0.2.2 and also access ftp on 10.0.2.2 however i cannot list directories (might need to play around with passive mode) but i cannot reach the internet
From the host i cannot ping the VM

marks
29-05-2013, 12:24
for the first issue: not sure why the transfer through FTP fails, unless it's something to do with memory management of such big file. Somehow, I would believe that scp should work better than ftp, but I haven't found this problem before, so I haven't checked it.

For the second issue: what type of network configuration are you using in proxmox? We support bridge mode, so that we can troubleshoot. Could you show us the network config of a test VM, please?

Thanks

makno
29-05-2013, 12:12
Hi everyone,

i am stuck trying to transfer the hd of a VM (250gb) from one servere to another. I have tried simply downloading it via ftp and it gets stuck at around 230gb.
Next i tried by splitting it in .rar archives and the actual splitting gets stuck at 93%
I have now tried to boot the system in rescue mode and mount the drive to split it but again:

split: vm-107-disk-1.raw: Input/output error

Any suggestions on how to get this across?

The second issue is that i have now moved all the failover ips to the new server and the VM can only run in nat mode, although it gets an ip adreess i can't get it to connect to the internet so i can't log in the box and upload to external ftp.

I have also tried by assignig the Vm an ipv6 but again no connectivity with that either (this would be the best solution i can think of so far)