OVH Community, your new community space.

Hyper-v help pls


rickyday
03-09-2013, 22:45
Sorry for the very late reply guys.

But to get this working you need to add a "trustedhost" to the WinRM listener config when using the default settings which use the HTTP transport.

Alternatively you can change the WinRM listener to use HTTPS which will involve utilising a certificate.

But has been said already you will have none of this mucking around if join the standalone server to a domain.

daddymax
29-08-2013, 18:23
Hi Andys,

Thanks for the link, however i have dumped the Hyper-c idea and moved back to what i know best.

Thanks again.

LinuxGam
28-08-2013, 20:35
Started this thread a bit late. ignore me.

AndyS
28-08-2013, 20:17
Quote Originally Posted by daddymax
@ AndyS
i have looked all over the internet for the openvpn setting guide on the server and i could't find it. i'll be grateful if you could point me to it.

Thanks for your help guys.
Sorry for the delay, this guide does the trick:

https://community.openvpn.net/openvp...tallingOpenVPN

Also, use the download link on the tutorial, v2.1.3, worked fine for me.

Let me know if you need anything else, or when you need the solution to nat though to the VMs

Trapper
27-08-2013, 00:53
Quote Originally Posted by AndyS
This drove me crazy for days.

If you are not using a domain it is a pain in the ass:
I too did the crazy thing of trying to get this to work for 2 days now. I do not give up easily, but have decided to try Xen Server.

~Trap

daddymax
25-08-2013, 18:02
@ AndyS
i have looked all over the internet for the openvpn setting guide on the server and i could't find it. i'll be grateful if you could point me to it.

Thanks for your help guys.

macole111
25-08-2013, 15:44
I can see why this is causing problems for people, it'll be the authentication due to not being on a domain. All my servers are on a domain so when I used Hyper-v server it didn't have any issues.

OpenVPN might be a good solution, I don't think the management traffic should really go over the internet.

-macole111

AndyS
25-08-2013, 13:54
This drove me crazy for days.

If you are not using a domain it is a pain in the ass:

My solution which works:

- Follow the usual steps to start remote management (Google Hyperv 2008 workgroup)

- Install OpenVPN on the server core (openssh is installed on the ovh hyperv so you can use winscp to upload the openvpn files). There is a guide in google to getting OpenVPN working on there.

- Install the client on your PC and VPN to the Hyperv

- Use the remote management tools (Server manager for firewall and Hyperv manager) to connect to the LOCAL ip on the OpenVPN network.

Let me know if you need more info.

daddymax
25-08-2013, 13:17
anyoldname thanks for the link, i tried that yesterday and it didn't help.

anyoldname
25-08-2013, 13:15
I've not tried this myself, but it may be usefull...

Hyper-V-Remote-Management

daddymax
25-08-2013, 12:57
Cool, well i have used hyper-v 2008 before and i don't remember having these issues.
i'll wait for your updates here.

Thanks a bunch
Max

Trapper
25-08-2013, 12:48
Hi daddymax,

I am going to re-install, as I see "Hyper-V R2" as an option (did not see this before). I guess this is the 2008 one.

I should then be in the same position as you, maybe we can help each other through this...!

BTW, for me, this is a machine which I will be expiring on the 9th of next month, so I am just using as a test-bed to learn about Hyper V...

~Trap

daddymax
25-08-2013, 12:22
Hi Trapper,
i have Hyper-v 2008 r2 and its driving me crazy.

Trapper
25-08-2013, 01:24
(Trying NOT to hijack the thread...)

I have an old EG, on which I have installed Hyper-V 2012.

I could not see the 2008 version in the OVH list, so I wonder if the OP means 2012.

Anywho. I am having exactly the same issue.

If we can get to the bottom of this, I'd gladly do some testing...

~Trap

daddymax
24-08-2013, 17:55
hmm i did that and still unable to connect.
i don't know what to do anyome.

aeh
24-08-2013, 17:43
Quote Originally Posted by daddymax
i just did.
i ran this cmd on both machines : netsh advfirewall firewall set rule group="Remote Volume Management" new enable=yes

but still no luck
By the look of it you'll need to open more than just the ports for remote volume management.

Easiest way to verify this, disable the firewall on the server for 5 min -> try it. If it works it is definitely a firewall policy issue.

daddymax
24-08-2013, 17:29
yes i can RDP but i can't connect via hyper-v manager

macole111
24-08-2013, 17:18
Can you connect via RDP to the server?

-macole111

daddymax
24-08-2013, 17:17
i just did.
i ran this cmd on both machines : netsh advfirewall firewall set rule group="Remote Volume Management" new enable=yes

but still no luck

aeh
24-08-2013, 17:14
You'll have to open the necessary ports on the server.

Sift through http://hardforum.com/showthread.php?p=1039124308 http://www.mediazone.nl/post/How-to-...r-R2-core.aspx http://pc-addicts.com/remotely-manag...ver-2012-core/ for what the minimum that needs opening is.

daddymax
24-08-2013, 17:05
i have disabled the firewall on my pc but i don't know if that needs to be done on the server as well.

aeh
24-08-2013, 17:02
I am assuming that you have already opened the relevant ports in the firewall?

daddymax
24-08-2013, 16:48
i have been trying to connect to my new hyper-v 2008 r2 server for the last 24h and i keep getting : http://prntscr.com/1n4q1l

i'm using windows 7 and have the Administration tools installed and hyper-v tools activated.

is there anything i should do on the server or does it come fully configured ?


Thanks