We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

port 25 blocked?


bago
11-11-2013, 22:48
Quote Originally Posted by Andy
Port 25 isn't blocked by OVH, so it's more than likely your firewall.
In italy OVH started blocking outgoing connections to port 25 from an IP after they internally detect spam. The way they detect spam IMHO is really weird.

BTW if OVH blocks an IP you receive an email saying why and how to use API v6 to check and eventually unblock the IP (after 1 hour, 24 hour or 30 days).

I don't know if this new policy/filter is enabled everywhere but in the italian forum there are a few users victim of the new filter.

village_i_diot
14-10-2013, 19:02
it does appear to be due to blacklist not propegated

telnet myvps.com 25 < -- fails (myvps.com is one of my vps servers)

telnet -b 1.1.1.1 myvps.com 25 <-- 1.1.1.1 is another ip on server and it connects OK

SO I assume I need to wait for the blacklist propagates

Thanks

village_i_diot
14-10-2013, 18:50
I used mxtoolbox.com which shows clear on all the lists they monitor.

the incident of the clients email being compromised was resolved over a week ago. the IP was removed from the blacklists though just over the past couple of days.

iptables shows no rules

Andy
14-10-2013, 18:03
Shouldn't stop it connecting to Google, it'll just send back a blocked message instead.

rickyday
14-10-2013, 17:52
Double check the IP in question is definitely removed from ALL blacklists, if it is it may take time to propagate and get removed completely from the blacklist databases.

Andy
14-10-2013, 17:24
Port 25 isn't blocked by OVH, so it's more than likely your firewall.

village_i_diot
14-10-2013, 17:02
I have an mSP with debian 6 and ispconfig 3 installed. For some reason outgoing email has stopped working.

in my mailq I am seeing messages such as :

(connect to alt4.gmail-smtp-in.l.google.com[173.194.79.27]:25: Connection timed out)

It's not just google, one such connection error is for one of my VPS's elsewhere so I tried telnetting to port 25, from my mSP and it just hangs. If I try telneting to the same server on port 25 from another server it connects fine.

One of my clients had their email compromised a few weeks ago and this led to the server being listed on a couple of blacklists but they have since removed the ip address so everything should be clear now.

Any suggestions why I am unable to connect to external IP addresses on port 25?

Thanks