We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

OVH Domain - KS Server - DNS Questions


JakeMS
20-10-2013, 09:35
Hey Jumbo,

Editing the posts here and removing the link will not get google to drop your result.

If you don't want google indexing you, you have a few options here:

1) Redirect the page to the correct location (301 response)
2) Request a removal from Google
3) Return a 404 (Google generally removes dead links)
4) Block them via robots.txt
5) Return 410 Gone (While this will remove you from Google, it may take Google longer to check back to re-index or it may not at all, you may need to resubmit if you intend to use the domain again)

If your just worried about a page which will be updated quite soon, just leave it and update it when ready, Google will update it's index quite soon after you have updated your website again (or it usually does)

Hope this helps :-).

J7mbo
19-10-2013, 17:54
Greg: I know it's not a big issue for you, but google has now indexed the previous page as the top result for my website - I was initially hesitant to post my domain on this forum because of that very reason. Is there any chance you could edit your post(s) to remove my domain name?

I'm intending to host my website and blog seperately (the blog runs on nodejs), as well as a few web applications I'm writing; one of which utilises ffmpeg for video conversion (hence I need good CPU speed). Mainly just a hackbox, but I like some power behind what I'm doing, so I got a 16G instead of a 2G.

I used to have a smaller box and I learned loads about sysadmin stuff from that, so now I'm scaling up. I'd love to get into virtualisation and how that all works. Maybe a little down the line...

gregoryfenton
19-10-2013, 13:44
Anytime, glad I could help
Purely out of interest, what are you using the KS16G for?

I turned mine into a proxmox host and run a bunch of virtual machines on there, it handles them beautifully

I have different VMs for different purposes and even different web sites. It was great fun putting it all together and getting it running

J7mbo
19-10-2013, 13:33
Hey Greg, it's working, thanks very much for the help. I can now use virtual hosts to control subdomains using mod_rewrite!

Thanks a lot for your help, very much appreciated

gregoryfenton
19-10-2013, 00:45
It's working
google domain name servers and openDNS domain name servers both give the correct result

dig @8.8.8.8

; <<>> DiG 9.9.3-rpz2+rl.13214.22-P2-Ubuntu-1:9.9.3.dfsg.P2-4ubuntu1 <<>> @8.8.8.8
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 6517
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;. IN A

;; ANSWER SECTION:
. 21418 IN A 176.31.125.166

;; Query time: 26 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Fri Oct 18 23:41:00 BST 2013
;; MSG SIZE rcvd: 64

Congratulations

J7mbo
19-10-2013, 00:29
I've updated the nameservers to:

dns200.anycast.me
ns200.anycast.me

Originally I changed these to the ovh / ks dns as I thought I had to.

So a 48 hour wait then

gregoryfenton
19-10-2013, 00:18
Ignore the bind stuff if you are not using it.

I notice that you say your DNS shows
ksXXXXXX.ovh.net
ns.kimsufi.com

Open your OVH Manager V3
click on the domain
Domains & DNS
DNS Servers
Modify
Delete the records in there
Primary: ns200.anycast.me
Secondary: dns200.anycast.me
Click Validate
When you have done that let me know, I am following the thread so it will email me.

This should fix the issue.
It will take up to 48 hours to propagate, but you can check instantly if you try
ping randomname.domain.com

Give it a few minutes before you do this so the OVH servers have time to update via cron.

J7mbo
18-10-2013, 23:49
I've changed the settings in /etc/bind/named.conf.options (never seen this file before actually), from:

listen-on port 53 { 127.0.0.1 ; };
listen-on-v6 { ::1; };

to the ones you suggested. Restarting bind9 gives the following error:

rndc: connect failed: 127.0.0.1#953: connection refused

For the record I haven't set up any extra dns stuff on my server, and I haven't changed any other settings really. A quick google says the above error is a permissions problem, but I don't have a group called "named" it seems.

gregoryfenton
18-10-2013, 23:17
dig @ks398377.ovh.net any

; <<>> DiG 9.9.3-rpz2+rl.13214.22-P2-Ubuntu-1:9.9.3.dfsg.P2-4ubuntu1 <<>> @ks398377.ovh.net any
; (1 server found)
;; global options: +cmd
;; connection timed out; no servers could be reached


You don't appear to have a DNS server running on your server. If you have, check /etc/bind/named.conf.options for
listen-on port 53 { any };
listen-on-v6 { any };

If they are not there, add them. They should be but may have 127.0.0.1 instead of any. Replace { 127.0.0.1 }; with { any };

The dns200.anycast.me DNS server provides the correct information.

You're almost done

Just make that change then
service bind9 restart

J7mbo
18-10-2013, 23:02
For the above: domain is domain.co.uk

Hi gregory, thanks for the reply.

I have added your wildcard dns setting as you suggested. The settings now look like this:

domain.co.uk A ip.ad.dr.ess
*.domain.co.uk A ip.ad.dr.ess

The NS settings are what concern me. In this "zone" section, they still say anycast (a whois to the domain disproves this though):

.domain.co.uk NS ns200.anycast.me
.domain.co.uk NS dns200.anycast.me

Even with the new wildcard added above, the domain still does not resolve. Do you have any other suggestions?

gregoryfenton
18-10-2013, 22:56
What's the domain? I will check it my end and see what IP I get.

gregoryfenton
18-10-2013, 22:10
You need to set wildcard in the DNS
*.domain.co.uk A ip.ad.dr.ess

Do this /after/ any strange IPs such as if you have a failover IP so they resolve correctly:

failover.domain.co.uk in a fa.il.ov.er
*.failover.domain.co.uk in a fa.il.ov.er
domain.co.uk A ip.ad.dr.ess
*.domain.co.uk A ip.ad.dr.ess

Save the cname for something useful, it just adds another call to a DNS record.

As for the apache stuff, I do it as follows:
Any subdomains
The domain
Default - "This is the default landing page"

// file /etc/apache/sites-available/blog.domain.co.uk.conf

ServerName blog.domain.co.uk
ServerAlias *.blog.domain.co.uk
DocumentRoot /var/www/blog.domain.co.uk


// file /etc/apache/sites-available/someothersub.domain.co.uk.conf

ServerName someothersub.domain.co.uk
ServerAlias *.someothersub.domain.co.uk
DocumentRoot /var/www/someothersub.domain.co.uk


// file /etc/apache/sites-available/domain.co.uk.conf

ServerName domain.co.uk
ServerAlias domain.co.uk *.domain.co.uk
DocumentRoot /var/www/domain.co.uk


// file /etc/apache/sites-available/catchall.conf

ServerName ksxxxxx.ovh.net
ServerAlias *
DocumentRoot /var/www/default


The catchall.conf one will grab every other attempt to connect with apache, whether it is by http://ip or a fake connection such as telnet 80 GET "http://idontexist HTTP/1.1"

I would also consider putting the virtualhost stuff in one file so you can ensure the correct order is followed. It is easy to forget to set the correct loading order in /etc/apache/sites-enabled/
0000-blog.domain.co.uk.conf -> ../sites-available/blog.domain.co.uk.conf
0010-someothersub.domain.co.uk.conf -> ../sites-available/someothersub.domain.co.uk.conf
0020-domain.co.uk.conf -> ../sites-available/domain.co.uk.conf
9999-catchall.conf -> ../sites-available/catchall.conf

J7mbo
18-10-2013, 21:54
Hi guys, I have a few questions about DNS / server settings and I was hoping someone could help me set up properly.

My use case:

- I have previously bought a .co.uk domain through ovh.
- I would like to host this on my dedicated kimsufi 16G server.
- I would also like the ability to create a subdomain, namely blog.domain.co.uk in the near future.

If I read right, I can use Apache to do this (it would be great if I could do this via Apache) - I'm currently attempting to use virtual hosts to do this, to no avail (I think first and foremost my dns settings are wrong)..

The first issue which led me to posting here: my domain does not resolve even though I changed the dns settings over 48 hours ago. Technical support directed me to these forums -.-

Here are my dns settings (according to Domains & DNS):

ksXXXXXX.ovh.net
ns.kimsufi.com

Great. Now if I go into "Dns Zone", it looks like this (wtf):

NS ns200.anycast.me
NS dns200.anycast.me
www.domain.co.uk A my-kimsufi-IP-address
www.domain.co.uk CNAME domain.co.uk

So there are some discrepancies there...

I won't go onto Apache vhost stuff yet, but (if I understand correctly), I want to be doing something like this:

// file domain.co.uk

ServerName domain.co.uk
ServerAlias domain.co.uk www.domain.co.uk
DocumentRoot /var/www/domain.co.uk


// file blog.domain.co.uk

ServerName blog.domain.co.uk
ServerAlias blog.domain.co.uk www.blog.domain.co.uk
DocumentRoot /var/www/blog.domain.co.uk


So...

1. What's up with the dns discrepencies? Are they even correct?
2. What am I doing wrong