We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Proxmox Failover IPs not working at all


AshleyUk
11-04-2014, 09:46
Hello,

If you want to spend me a PM can dedintly have a look and help you get it working.

,Ashley

ElectricDuck
11-04-2014, 02:47
Quote Originally Posted by Myatu
It *might* be an issue with OVH's routing. You can get a more definitive answer when you run tcpdump on the Proxmox host to capture ICMP packets, and then run a ping from within the guest. Regardless if it is able to reach the internet or not, you should see that come up in a tcpdump. For a quick cheat sheet on tcpdump, see: http://www.rationallyparanoid.com/articles/tcpdump.html -- replace "eth0" with the correct interface, of course.
Tried tcpdump on multiple devices and listened for pings, but couldn't retrieve anything. Windows can't seem to ping the host either (via .254). However, the network status windows says it's connected but no Internet access.

Pretty much hitting a brick wall everytime here. I really cannot figure out what's going on.


Myatu
09-04-2014, 14:26
Quote Originally Posted by ElectricDuck
Tried reverting "add route" ("del route"). Didn't work.
Can't ping anything. Can't ping my IP from outside OVH either.

Should I bring this up with OVH?
It *might* be an issue with OVH's routing. You can get a more definitive answer when you run tcpdump on the Proxmox host to capture ICMP packets, and then run a ping from within the guest. Regardless if it is able to reach the internet or not, you should see that come up in a tcpdump. For a quick cheat sheet on tcpdump, see: http://www.rationallyparanoid.com/articles/tcpdump.html -- replace "eth0" with the correct interface, of course.

ElectricDuck
09-04-2014, 13:37
Quote Originally Posted by Myatu
Make sure the veth device is connected to vmbr0, don't use "add route" as in your original post and ensure you don't have any firewalls running on either host or container.

On the host, you can also use tcpdump to see what's happening with ICMP traffic (when you ping an address, say, 8.8.8.8, from within the guest).
Tried reverting "add route" ("del route"). Didn't work.
Can't ping anything. Can't ping my IP from outside OVH either.

Should I bring this up with OVH?

Myatu
07-04-2014, 17:35
Make sure the veth device is connected to vmbr0, don't use "add route" as in your original post and ensure you don't have any firewalls running on either host or container.

On the host, you can also use tcpdump to see what's happening with ICMP traffic (when you ping an address, say, 8.8.8.8, from within the guest).

ElectricDuck
06-04-2014, 23:31
Quote Originally Posted by RikT
Well check you have the correct mac and also the correct type of mac as well I would bet that the mac is the issue
Checked. Re-checked. Generated a new one (an "ovh" one). Restarted the VM for good measure, and still no Internet.

Should I elevate this issue to OVH?

It doesn't seem to be a problem with Proxmox, because I can connect to my IPv6s with no problems whatsoever.

RikT
06-04-2014, 02:41
Quote Originally Posted by ElectricDuck
I did actually do that first time round. However, I've tried it again. Windows now reports "No Internet access" on the IPv4 (which switches to "No network access" and then back to "No Internet access" repeatedly), so it is actually connecting to something. Also, I can't ping my gateway.
Well check you have the correct mac and also the correct type of mac as well I would bet that the mac is the issue

ElectricDuck
05-04-2014, 22:33
Quote Originally Posted by RikT
What type of virtual mac did you create was it a ovh mac address or vmware mac address as the vmware mac's dont work with proxmox.
Also I dont think you have to use regedit to add that subnet anyways on 2012 as you didnt on 2008


also i believe the settings should be


IPv4 Address:
IPv4 Subnet Mask: 255.255.255.255
IPv4 Default Gateway: server main ip end with .254 in your case 37.187.141.254
IPv4 DNS Server: 213.186.33.99 or as i use googles dns 8.8.8.8 and 8.8.4.4

as in the ovh guide here http://help.ovh.co.uk/BridgeClient
I did actually do that first time round. However, I've tried it again. Windows now reports "No Internet access" on the IPv4 (which switches to "No network access" and then back to "No Internet access" repeatedly), so it is actually connecting to something. Also, I can't ping my gateway.

ElectricDuck
05-04-2014, 22:25
Quote Originally Posted by LinuxGam
Well... being as they are on the same physical machine, then you would expect a traceroute from your home connection for example to take exactly the same route right up until the last hop, unless the the fail over was not routing correctly, which is out of your control.

I don't really like the tone of your reply at all, considering I was just trying to help and you can't even copy paste and correctly.. Good luck fixing it without any further help from myself.
"I don't really like the tone of your reply at all"

I don't know how you interpreted my reply, but it wasn't meant to be insulting.

LinuxGam
05-04-2014, 08:20
Quote Originally Posted by ElectricDuck
Yes, that is a typo >.>

Also, how on earth is it going to traceroute to the host OS, since it's bridging to eth0.
Well... being as they are on the same physical machine, then you would expect a traceroute from your home connection for example to take exactly the same route right up until the last hop, unless the the fail over was not routing correctly, which is out of your control.

I don't really like the tone of your reply at all, considering I was just trying to help and you can't even copy paste and correctly.. Good luck fixing it without any further help from myself.

RikT
05-04-2014, 04:02
Quote Originally Posted by ElectricDuck
I've spent almost two hours and I've got nowhere. I cannot for the life of me get my failover IPv4s working in Proxmox VMs.

My server IP is 37.187.141.207.
The FO I'm trying to add is 178.33.180.129.
I've setup the virtual MAC address in OVH's control panel and added it to Proxmox.
Also ran "ip route add 178.33.180.129 dev vmbr0" on Proxmox

My VM -- Windows Server 2012R2 -- is setup like this...
IPv4 Address: 178.33.180.192
IPv4 Subnet Mask: 255.255.255.255 (added via the regeit hack)
IPv4 Default Gateway: 178.33.180.254
IPv4 DNS Server: 213.186.33.99

Even after all of this, Windows refuses to connect.

What am I doing wrong!?

What type of virtual mac did you create was it a ovh mac address or vmware mac address as the vmware mac's dont work with proxmox.
Also I dont think you have to use regedit to add that subnet anyways on 2012 as you didnt on 2008


also i believe the settings should be


IPv4 Address:
IPv4 Subnet Mask: 255.255.255.255
IPv4 Default Gateway: server main ip end with .254 in your case 37.187.141.254
IPv4 DNS Server: 213.186.33.99 or as i use googles dns 8.8.8.8 and 8.8.4.4

as in the ovh guide here http://help.ovh.co.uk/BridgeClient

ElectricDuck
05-04-2014, 01:01
Quote Originally Posted by LinuxGam
I hope this is just a typo right?
Yes, that is a typo >.>

Also, how on earth is it going to traceroute to the host OS, since it's bridging to eth0.

LinuxGam
05-04-2014, 00:13
Quote Originally Posted by ElectricDuck
I've spent almost two hours and I've got nowhere. I cannot for the life of me get my failover IPv4s working in Proxmox VMs.

The FO I'm trying to add is 178.33.180.129.
IPv4 Address: 178.33.180.192
I hope this is just a typo right?

LinuxGam
05-04-2014, 00:08
Have you done traceroute to see if it gets to the host server in case it's some random routing issue out of your control.

ElectricDuck
04-04-2014, 23:16
I've spent almost two hours and I've got nowhere. I cannot for the life of me get my failover IPv4s working in Proxmox VMs.

My server IP is 37.187.141.207.
The FO I'm trying to add is 178.33.180.129.
I've setup the virtual MAC address in OVH's control panel and added it to Proxmox.
Also ran "ip route add 178.33.180.129 dev vmbr0" on Proxmox

My VM -- Windows Server 2012R2 -- is setup like this...
IPv4 Address: 178.33.180.192
IPv4 Subnet Mask: 255.255.255.255 (added via the regeit hack)
IPv4 Default Gateway: 178.33.180.254
IPv4 DNS Server: 213.186.33.99

Even after all of this, Windows refuses to connect.

What am I doing wrong!?