OVH Community, your new community space.

ProFTP Config help


ctype_alnum
22-06-2014, 08:48
I don't know how much stuff proftpd actually logs because I use SFTP for everything thesedays but in future try checking the system logs. You can run something like:

tail /var/log/secure or if you want to keep it updating on screen watch -n 1 tail /var/log/secure

ezdub
22-06-2014, 07:34
It's OK figured it out, forgot that because there is a space in the directory name have to add quotes.

IE:

If anyone is interested.

ezdub
21-06-2014, 08:37
Hi guys got a bit of brain freeze and for the life of me can not get a new ftp permissions to work correctly on a new directory.

I have previously set-up a ftp directory with limited read and write access which works correctly.

Now I have set up a new directory on the same domain and trying to limit permissions in that directory but all ftp users can read/right and delete when I only want one user to have read/right and delete and all others read only access.

Limiting new ftp users to the new directory is fine but the read only access is just not working, they can do what they want.

This part in proftp config is working fine:

Code:

	GroupOwner	psacln




AllowUser UPLOADUSER
AllowUser USER01
DenyAll

But when I add the new config for the new directory and ftp user permissions it will not work.

Code:

	GroupOwner	psacln




AllowUser UPLOADUSER
AllowUser USER01
DenyAll





AllowUser USER02
DenyAll



# Enable PAM authentication
AuthPAM on
AuthPAMConfig proftpd

IdentLookups off 
UseReverseDNS off

AuthGroupFile	/etc/group

Include /etc/proftpd.include
So this is the part not working

Code:


AllowUser USER02
DenyAll

I am sure it is just a simple mistake I have made just can not figure it out.

Hope you can help thanks guys.