OVH Community, your new community space.

Windows 2012 Standard - Virtual Machine Networking issues.


Neil
11-07-2014, 17:19
Hi

Pleased it is all sorted

MonkeyDrone
11-07-2014, 15:29
Got it to work.
Steps are here in case anyone else runs into trouble. There is simply no guide out there that would make our lives easier.

Step 1 ) Purchase Failover IPs from your OVH control panel.
Step 2) Assign a Virtual Mac address to your Failover IP
Step 3) In Hyper-V, goto Virtual Switch Manager -> Global Network Settings. Enter your Newly acquired mac address there.
Step 4) Follow the guide at http://help.ovh.co.uk/BridgeClient
Step 5) Successfully connected to the internets.

Good luck
BTW: This took me 2 days to figure out.

MonkeyDrone
11-07-2014, 15:04
I bought a failover IP and did the following changes and still no luck with connectivity
Failover IP = 91.121.x.140
Dedicated Server IP = 37.187.x.183


My settings are as follows [x == hidden for forum post]
auto eth0
iface eth0 inet static
address 91.121.x.140
netmask 255.255.255.255
broadcast 91.121.x.140
post-up route add 37.187.x.254 dev eth0
post-up route add default gw 37.187.x.254
post-down route del 37.187.x.254 dev eth0
post-down route del default gw 37.187.x.254

MonkeyDrone
11-07-2014, 14:09
In Hyper-V, I created an external network so I could use with my VMs.
I have created a VM in Hyper-V manager. Installed Ubuntu 14.04 LTS server edition in it. The installation failed to auto detect network settings.
I finished my installation of Ubuntu and now I tried manually configuring the network device following the guide here http://help.ovh.co.uk/BridgeClient

My settings are as follows [x == hidden for forum post]
auto eth0
iface eth0 inet static
address 37.187.x.183
netmask 255.255.255.255
broadcast 37.187.x.183
post-up route add 37.187.x.254 dev eth0
post-up route add default gw 37.187.x.254
post-down route del 37.187.x.254 dev eth0
post-down route del default gw 37.187.x.254

and in the resolv.conf i have
nameserver 213.186.33.99

I've no connectivity to the internet and I can't even ping the gateway address. The two routes in those lines show up in the routing table.
What is going wrong here? What am I missing in the configuration here that is not allowing connectivity. The external virtual connection in hyper-v looks good. Network device shows up in control panel in windows that a virtual NIC is installed and running.

Edit: Just to clarify the error i get when i ping the Gateway us "Destination Host Unreachable"

Also, do I need to buy extra IPs besides the IP provided for the dedicated machine to get the VMs working?