OVH Community, your new community space.

What am I doing wrong ? Please help!!! (Fail-over IPs unable to configure)


heise
09-08-2014, 19:28
contact me on skype or email if you like

newmanx
09-08-2014, 19:12
Adding IPs to centos (stand-alone) works, but Virtual MAC IDs are not required for just adding ips in stand alone OS.
It could be router Issue like i read in some thread or something which i am unable to figure out.

looks like i need somebody to fix this for me, PM me if anyone interested and i can pay via paypal and get this done with.

newmanx
09-08-2014, 19:05
Quote Originally Posted by heise
What do you mean with pool-wide network and network1? You should only have one network card connected to the internet and that is the only one you should be using. That is the one connected to xenbr1 and your VM should also connect to it.
It was automatically created, I re-installed xenserver again and this time there was only 1 entry that is Network1, i tried the default template installation on SYS and made no changes, then i created VMS, added the virtual MAC, modified the interfaces file....still no luck, it doesn't work.

could it be the router issue in SYS? or i am simply missing something ?
meantime i am installing stand-alone centos6.5 and trying if secondary failover ips are working normally without any VMs.

I am willing to pay anyone who can fix this for us and also educate us for other IPs.

heise
09-08-2014, 18:32
Pool-wide network associated with eth0
Network 1 - bridged with eth1 - set MAC address of VMs to the values obtained from OVH
What do you mean with pool-wide network and network1? You should only have one network card connected to the internet and that is the only one you should be using. That is the one connected to xenbr1 and your VM should also connect to it.

newmanx
09-08-2014, 17:19
Quote Originally Posted by heise
Even though XenServer has its moments, why don't you use Ubuntu or CentOS with Gnome and KVM/Qemu? Makes configuration through VNC easy.

If I recall Xen correctly, it sets up xenbr0 (xenbridge). So you should connect your VM to that network. I guess you have a problem with the host configuration, since the guest looks fine.
@heise, thanks for your reply, I have been trying SYS support since last 30+ hrs and they have washed their hands and doesnt want to intervene, we are actually setting up heart-beat server and we need Xenserver as we have used the same in other DC, i guess i have no other option than to fix it.

our Host server is setup as xenbr1 and not xenbr0, any tips where the problem could be ? your help is much appreciated.

heise
09-08-2014, 15:04
Even though XenServer has its moments, why don't you use Ubuntu or CentOS with Gnome and KVM/Qemu? Makes configuration through VNC easy.

If I recall Xen correctly, it sets up xenbr0 (xenbridge). So you should connect your VM to that network. I guess you have a problem with the host configuration, since the guest looks fine.

newmanx
08-08-2014, 17:26
Hi

I got a new server (soyoustart), then went about all articles in setting up the network, i paid and ordered extra 16IPs and got allocated to my main IP in no time, then installed Xenserver 6.2 with SP1 and setup drive's with No Raid, but stuck very badly since this morning trying to pass the fail-over IPs to my VMs.

I exactly did what this Doc said: http://help.ovh.co.uk/BridgeClient
but am unable to make the VM up with that IP and no technical support from the back-end so cant proceed further, if this was any software issue we would have fixed and not bothered anyone, but this is the first time we are using OVH and their way of setup is different from other DCs, so could someone please help us, what wrong we are doing here ?

Main IP: 37.XX.11.123
FailoverIP (16): 92.XX.109.96/28
Virtual MAC Filter configured for: 92.XX.109.99 (02:00:00:75:10:d2)

Citrix Xenserver Hypervisor: 37.XX.11.123
Server Networks:
Pool-wide network associated with eth0
Network 1 - bridged with eth1 - set MAC address of VMs to the values obtained from OVH

Network1:
37.XX.11.123
255.255.255.0
37.XX.11.254
DNS: 213.186.33.99

Ubuntu VM (/etc/network/interface):
# The loopback network interface
auto lo
iface lo inet loopback
# The primary network interface
auto eth0
iface eth0 inet static
address 92.XX.109.99
netmask 255.255.255.255
broadcast 92.XX.109.99
post-up route add 37.XX.11.254 dev eth0
post-up route add default gw 37.XX.11.254
pre-down route del 37.XX.11.254 dev eth0
pre-down route del default gw 37.XX.11.254



Thanks