OVH Community, your new community space.

Multiple NICs under guest OS VMware


swanseahost
27-11-2014, 01:26
http://forum.ovh.co.uk/showthread.ph...ll=1#post66624

heise
28-10-2014, 13:54
Why don't you post your changed metrics back? You do understand the concepts of metrics? If you have two gateways, one with metric 0 and the other one with metric 1, all traffic will go out through the gateway with metric 0, right? I don't know, which applications you had in mind, but if you want traffic of eth1 to be answered on eth1 and traffic of eth0 to be answered on eth0, you will need to set complex firewall rules.

vaarsn
28-10-2014, 12:51
Quote Originally Posted by heise
Code:
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.99.161.254  0.0.0.0         255.255.255.255 UH    0      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     1002   0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     1003   0        0 eth1
0.0.0.0         192.99.161.254  0.0.0.0         UG    0      0        0 eth0
Hi, I told you, you have to route the traffic in a proper way. Here you see that eth0 has metric 0 and all traffic will go through eth0. If you setup a second network card, are you setting the metric correctly? I am asking, because until now, you did not publish any config files, we could take a look at.

The commands you publish just can't work.
It doesn't work. I tried with metrics as well. It could be a problem with OVH gateway for my account. I called their support. Let's see how can they fix that.

heise
28-10-2014, 06:43
Code:
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.99.161.254  0.0.0.0         255.255.255.255 UH    0      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     1002   0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     1003   0        0 eth1
0.0.0.0         192.99.161.254  0.0.0.0         UG    0      0        0 eth0
Hi, I told you, you have to route the traffic in a proper way. Here you see that eth0 has metric 0 and all traffic will go through eth0. If you setup a second network card, are you setting the metric correctly? I am asking, because until now, you did not publish any config files, we could take a look at.

The commands you publish just can't work.

vaarsn
27-10-2014, 21:03
Googling doesn't work. Guys, what is going on? My second nic can't be routed when 1st enabled and vice versa.

vaarsn
25-10-2014, 19:10
Please help me with that

vaarsn
24-10-2014, 12:49
Thank you for the teaching me. I still can find related post. Can you just provide me with the link?

heise
24-10-2014, 00:02
Hi, well first of all, the OVH help that you state, is about assigning one network card to one VM. So each VM has one indepentent network card with own IP. If you want to run multiple network cards inside one VM, then you have to setup proper routing, d.h. how you VM will determine which networkcard to use to access the internet. Otherwise your VM will not know, how to access the internet, hence no connection. There was a similar post like a week or two ago. Use search function.

vaarsn
23-10-2014, 20:59
Can somebody help me?

vaarsn
22-10-2014, 20:53
Hi,

I want to assign a few adapters to my Guest OS (it's CentOS). According to this manual http://help.ovh.co.uk/bridgeclient I configured my eth0 adapter, but I can't enable second (eth1) adapter in accordance with the manual above.
1. I generaded VMAC for my second IP in SYS panel.
2. I assigned this MAC to the second NIC in VMware.
3. I had changed eth1 settings in accordance with manual
4. I had added route-eth1 routes in accordance to manual above.

While doing
Code:
service network restart
I'm getting the next:

Code:
Bringing up interface eth1:  Determining if ip address 192.99.140.9 is already in use for device eth1...
RTNETLINK answers: File exists
RTNETLINK answers: No such process


Code:
root@srv [~]# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.99.161.254  0.0.0.0         255.255.255.255 UH    0      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     1002   0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     1003   0        0 eth1
0.0.0.0         192.99.161.254  0.0.0.0         UG    0      0        0 eth0
Code:
root@srv [~]# cat /etc/sysconfig/network-scripts/route-eth0
192.99.161.254 dev eth0
default via 192.99.161.254 dev eth0
Code:
root@srv [~]# cat /etc/sysconfig/network-scripts/route-eth1
192.99.161.254 dev eth1
default via 192.99.161.254 dev eth1