OVH Community, your new community space.

Linux server in ESXi box wont connect to external IPs, routing issue?


Jackster
18-11-2014, 02:31
It doesn't work on its own I doubt that would :/

(as in just eth0 with settings for just the 5.x.x.x IP)

heise
18-11-2014, 02:28
Broadcast is same IP as IPADDR.
If you have more than 1 network card, then make the maths. Are you telling your system how to route the traffic, e.g. when to use eth0 and when to use eth1? The easy way is to use IP alias.

Jackster
17-11-2014, 13:30
Quote Originally Posted by heise
Broadcast is wrong.
BOOTPROTO=none
I hope, there is no ifcfg-eth0 on the server?
Support staff said 255.255.255.255 was correct :?
And yes there is. Why is that a problem?

heise
16-11-2014, 20:50
Broadcast is wrong.
BOOTPROTO=none
I hope, there is no ifcfg-eth0 on the server?

Jackster
16-11-2014, 17:43
So I have been trying to get this to work for days now.

I have a ESXi box hosting multiple machines.

The Windows ones are fine, they all connect to IP failerovers fine.
But Linux machines don't. I have used the same settings for both but the Linux ones never connect.

Here are my settings in CentOS, ifcfg-eth1 on left, route-eth1 on right.


I have set the MAC address in ESXi to the one generated in the manager.

What am I doing wrong?