OVH Community, your new community space.

Can someone walk me through the setup of a VM network?


john_gb
08-12-2014, 19:34
One other small thing that can catch you out with xen hypervisors and allocating failover IP to a vm, is, you must ensure ip_forwarding=1 is set (default is 0) on the xen host. It's in /etc/sysctl.conf
This allows routing of the failover IP between the host interface and the vm interface (vif). Also a good idea to code the routing into your vm.cfg file like this:

vif = ['ip=188.165.5.69,script=vif-route']

The scripts are standard in Xen, this adds the route from 188.165.5.69 to the host IP to the hosts routing tables when the vm is created. There are similar scripts for bridging.

Dani
27-11-2014, 11:15
Hi

It appears the IP isn't an OVH IP:

inetnum: 5.168.0.0 - 5.169.255.255
netname: TIM-NET
descr: TIM
descr: Telecom Italia Mobile
descr: Service Provider
country: IT
admin-c: FP3192-RIPE
tech-c: GF3559-RIPE
tech-c: MM27810-RIPE
status: ASSIGNED PA


Danny

swanseahost
27-11-2014, 01:18
Hi,

I can see that you already have route-eth0 (in another post) and will assume you using centos 6.x inside vmware esxc. Centos made a major change on routing which causes issues with esx and OVH.

Complete the following and it should work for you.... Worked for me and took ages to find it... Centos 5 does not have this issue...

Temporary change

To accept asymmetrically routed (outgoing routes and incoming routes are different) packets set "rp_filter" to 2 and restart networking, by running the following commands:

# echo 2 > /proc/sys/net/ipv4/conf/default/rp_filter
# echo 2 > /proc/sys/net/ipv4/conf/all/rp_filter

Persistent change

To make this behaviour persistent across reboots, modify /etc/sysctl.conf and make the following change prior to reboot:

net.ipv4.conf.default.rp_filter = 2

Good Luck!

Let me know if this helped you please.

Jackster
23-11-2014, 22:32
Quote Originally Posted by heise
I can only guess, but MAC 02 : 00 : 00 : DE : 75 : 26 is associated to fail-over IP 5.169.200.207, right? In that case everything looks fine.

ESXi and Proxmox are configured right, I assume. I never used those OS. I use CentOS with KVM and it looks pretty similar.
Yes it is.
Checked with ovh support to and they can't see what is wrong

heise
23-11-2014, 21:48
I can only guess, but MAC 02 : 00 : 00 : DE : 75 : 26 is associated to fail-over IP 5.169.200.207, right? In that case everything looks fine.

ESXi and Proxmox are configured right, I assume. I never used those OS. I use CentOS with KVM and it looks pretty similar.

Jackster
23-11-2014, 21:01
Already tried it, never works.


heise
23-11-2014, 17:06
Google ip ovh bridge. There tutorial should tell you everything you need to know.

Jackster
23-11-2014, 09:49
I can not for the life of me get this working.

I have tired in ESXi and Proxmox to get a VM to connect to a fail over IP but they never work.
Have had 20 people look at this and come up with no answer, they all say OVH's network is ****ed up....

Someone please walk me through setting up the network on one of these please!

Jack,