OVH Community, your new community space.

Outbound failover ip?

26-11-2014, 19:53
Because it's your main IP. If you want connections to look like they're coming from your failover IP, you'll need to do something like this:

iptables -t nat -A POSTROUTING -o eth0 -j SNAT --to-source

bob cat
25-11-2014, 13:57
why does wget output the wrong ip inspite of me setting the ip to bind and the route entry?

root@vps43466:~# ip route show

default via 37.XXX.87.254 dev eth0
37.XXX.87.0/24 dev eth0 proto kernel scope link src 37.XXX.87.144
37.XXX.235.0/24 dev eth0 proto kernel scope link src 37.XXX.235.0 dev gre1 proto kernel scope link src

root@vps43466:~# wget --bind-address=37.XXX.235.157 -qO- ; echo


inside networking config -

post-up /sbin/ifconfig eth0:2 37.XXX.235.157 netmask broadcast 37.XXX.235.157
post-down /sbin/ifconfig eth0:2 down

*.144 is the main ip
*.157 is a failover ip