OVH Community, your new community space.

SolusVM KVM IPv6 Issue - E3-SAT-3


rmlhhd
15-12-2014, 19:02
Hello All,

I'm having issues with IPv6 on my server, I'm going to be hosting KVM VPS's for a project I have. The node it's self can access the internet via IPv6 and the KVM VPS's can access the internet via IPv4 but not V6.

Here's some configuration -

Node -

IP6Tables is disabled.

cat /etc/sysconfig/network
NETWORKING=yes
HOSTNAME=****
NOZEROCONF=true
GATEWAY=37.59.**.***
NETWORKING_IPV6=yes
IPV6FORWARDING=yes
IPV6_DEFAULTGW=2001:41d0:8:67FF:FF:FF:FF:FF

cat /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
ONBOOT=yes
BRIDGE=br0

cat /etc/sysconfig/network-scripts/ifcfg-br0
DEVICE=br0
TYPE=Bridge
BOOTPROTO=static
IPADDR=37.59.44.**
NETMASK=255.255.255.0
ONBOOT=yes
GATEWAY=37.59.44.254
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6ADDR=2001:41D0:8:673d::1/64
DELAY=0
ARPCHECK=no

cat /etc/sysconfig/network-scripts/route6-eth0
2001:41D0:8:67ff:ff:ff:ff:ff dev eth0
default via 2001:41D0:8:67ff:ff:ff:ff:ff

cat /etc/sysconfig/network-scripts/route6-br0
2001:41d0:8:67ff:ff:ff:ff:ff dev br0
default via 2001:41d0:8:67ff:ff:ff:ff:ff

sysctl -p
net.ipv4.conf.default.rp_filter = 1
net.ipv4.conf.default.proxy_arp = 0
net.ipv4.conf.default.accept_source_route = 0
kernel.sysrq = 0
kernel.core_uses_pid = 1
net.ipv4.tcp_syncookies = 1
net.bridge.bridge-nf-call-ip6tables = 0
net.bridge.bridge-nf-call-iptables = 0
net.bridge.bridge-nf-call-arptables = 0
kernel.msgmnb = 65536
kernel.msgmax = 65536
kernel.shmmax = 68719476736
kernel.shmall = 4294967296
net.ipv6.conf.all.autoconf = 0
net.ipv6.conf.default.autoconf = 0
net.ipv6.conf.eth0.autoconf = 0
net.ipv6.conf.all.accept_ra = 0
net.ipv6.conf.default.accept_ra = 0
net.ipv6.conf.eth0.accept_ra = 0
net.ipv4.ip_forward = 1
net.ipv6.conf.all.forwarding = 1
net.ipv6.conf.br0.forwarding = 1
net.ipv6.conf.default.forwarding = 1
net.ipv6.conf.all.proxy_ndp = 1

KVM VPS -

iface eth0 inet6 static
address 2001:41d0:8:673d::2
netmask 64
post-up /sbin/ip -f inet6 route add 2001:41d0:8:67ff:FF:FF:FF:FF dev eth0
post-up /sbin/ip -f inet6 route add default via 2001:41d0:8:67ff:FF:FF:FF:FF
pre-down /sbin/ip -f inet6 route del default via 2001:41d0:8:67ff:FF:FF:FF:FF
pre-down /sbin/ip -f inet6 route del 2001:41d0:8:67ff:FF:FF:FF:FF dev eth0

ping6 google.com
PING google.com(2a00:1450:400c:c07::65) 56 data bytes
From 2001:41d0:8:673d::2 icmp_seq=1 Destination unreachable: Address unreachable
From 2001:41d0:8:673d::2 icmp_seq=2 Destination unreachable: Address unreachable
From 2001:41d0:8:673d::2 icmp_seq=3 Destination unreachable: Address unreachable

ping6 2001:41d0:8:67ff:FF:FF:FF:FF
PING 2001:41d0:8:67ff:FF:FF:FF:FF(2001:41d0:8:67ff:ff:f f:ff:ff) 56 data bytes
From 2001:41d0:8:673d::2 icmp_seq=1 Destination unreachable: Address unreachable
From 2001:41d0:8:673d::2 icmp_seq=2 Destination unreachable: Address unreachable
From 2001:41d0:8:673d::2 icmp_seq=3 Destination unreachable: Address unreachable

ping6 2001:41d0:8:673d::1
PING 2001:41d0:8:673d::1(2001:41d0:8:673d::1) 56 data bytes
64 bytes from 2001:41d0:8:673d::1: icmp_seq=1 ttl=64 time=0.121 ms
64 bytes from 2001:41d0:8:673d::1: icmp_seq=2 ttl=64 time=0.044 ms
64 bytes from 2001:41d0:8:673d::1: icmp_seq=3 ttl=64 time=0.045 ms


I phoned SYS and they said they'd send me an email with a guide but never did, could someone help?

I'll provide more config if needed.