We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Not receiving emails until reboot?


arewenotmen
22-03-2008, 17:04
Found the problem... I got it again, and tried telnetting in to send email via raw SMTP. Some went through, some gave me:

451 qq temporary problem (#4.3.0)

Apparently this is a problem with clamd, so I restarted it, and it's OK again. I haven't looked into solving that yet.

arewenotmen
19-03-2008, 22:58
Well, so far I've seen it happen once more. I tried restarting courier-imapd and Bind but no obvious difference - though it's hard to tell. This seems to be a problem when the server is under load - MySQL also fails and has to be manually restarted.

I see lots of this in the syslog:

Mar 16 23:46:36 ks355007 collectd[4893]: No sleeping because `timeval_sub_timespec' returned non-zero!

but I think that's a symptom, not a cause.

Next time it fails I'll try sending mails directly via Telnet and see what it says.

sledge0303
16-03-2008, 09:51
May your MTA/IMAPd server was interrupted? Have you tried to restart both services by console? If yes, an error message occurred then?

arewenotmen
15-03-2008, 23:24
I'm running Gentoo with QMail.

Every once in a while (days) I notice that I've suddenly stopped getting new emails. Last time I had a look at the server once this had happened, and found:

* nothing in the queue
* disk space is fine
* I can log in and read old mail OK, just not receive any new mails
* mails sent from within the server are received
* restarting individual services like qmail, sqwebmail etc seemed to make no difference
* the DNS tools report says everything's OK
* I can't see anything useful in /var/logs or qmail logs but it may have been a problem in yesterday's logs instead - will investigate

I rebooted the server and within a couple of minutes I picked up a load of backdated mail.

Any ideas?

e2a: this is ks355007.kimsufi.com which hosts mail.wapoc.com