We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Ports blocked?


HyperTextCoffee
17-03-2015, 16:36
Update: Linux was the culprit, the network service kept crashing. I've solved it by purchasing a licence for Server 2012 and now it works great. Thanks everyone for your help

HyperTextCoffee
16-03-2015, 16:31
The only port listening on 0.0.0.0 is port 21....... which is a port that is reported as open.

I THINK it's because the GameCP software was listening on 127.0.0.1 and not 0.0.0.0. Could OVH change the network configuration so that I can listen out on 127.0.0.1, purely because most Windows programs are hardcoded to listen on 127.0.0.1?

I think we're getting somewhere

Edit: I'm an *****, of course stuff can't listen OUT on 127.0.0.1, because that's local-only

Careimages
16-03-2015, 16:00
A 'closed' port suggests that there is no process listening on it?

do
netstat -tlpn

to show all processes listening on tcp sockets.

HyperTextCoffee
16-03-2015, 13:50


And iptables is set to accept all traffic. So I'm stuck.

HyperTextCoffee
16-03-2015, 13:24
Quote Originally Posted by alvaroag
Try with "ufw disable", maybe you have the "Uncomplicated firewall" enabled by default, it's the recommended alternative by Ubuntu.

alvaroag
16-03-2015, 12:59
Try with "ufw disable", maybe you have the "Uncomplicated firewall" enabled by default, it's the recommended alternative by Ubuntu.

HyperTextCoffee
16-03-2015, 12:17
Quote Originally Posted by alvaroag
As far as I know, OVH/SYS does not implement any firewall, at least by default. Maybe it's something to do with a distro-default iptables configuration, used to happen to me with centos. You can stop iptables "/etc/init.d/iptables stop" and try to connect again. Also, make sure your app is listening on "0.0.0.0", not "127.0.0.1"
Doesn't let me run "/etc/init.d/iptables stop"; "/etc/init.d/iptables: No such file or directory". Is it located elsewhere in Ubuntu 12.04?

HyperTextCoffee
16-03-2015, 11:56
Hi marks,the server name is ns374460.ip-188-165-241.eu, and I will go try alvaroag's suggestion now, and report back

marks
16-03-2015, 11:32
no, no block or firewall by default to limit the access to your port at all. as alvaroag says, do check your software firewall , but definitely no block, by default, on our side. Do give us the server name if you want us to check further.

Thanks.

alvaroag
16-03-2015, 06:43
As far as I know, OVH/SYS does not implement any firewall, at least by default. Maybe it's something to do with a distro-default iptables configuration, used to happen to me with centos. You can stop iptables "/etc/init.d/iptables stop" and try to connect again. Also, make sure your app is listening on "0.0.0.0", not "127.0.0.1"

HyperTextCoffee
15-03-2015, 22:22
Hello,
So I purchased the staggered monthly plan on a server yesterday, but it seems as though all ports except 443 and 21 are blocked by default? I'm using the Ubuntu 12.04 Desktop distro, and I had Windows Server running in VMWare, however I installed GameCP on a separate web host and it can't connect to the server on port 240. I even tried a non-standard port but it still doesn't work.

Now, is it to do with iptables on the Linux host, or does OVH/SYS explicitly block most ports?

I'd really like to get this sorted, because I don't want to cancel and have to go through the hassle of finding another host.

Thanks, George